pragmaMx Support Forum pragmaMx Support Forum

Fehler bei SMF Standalone to pragmaMX konvetierung...

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline TrippleEx

  • **
  • 85
  • +0/-0
Fehler bei SMF Standalone to pragmaMX konvetierung...
« am: 05 Oktober 2007, 01:45:53 »
Könnte mal die Anleitung zu der o.g. Migration die Anleitung nicht etwas genauer Schreiben ?
Was muss den konkret bei dem Setting Repair Tool eingestellt werden ?




Beim aufruf von convert.php bekomme die Meldung:

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in G:\xampp\htdocs\pmx\modules\Forum\smf\convert.php on line 275

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in G:\xampp\htdocs\pmx\modules\Forum\smf\convert.php on line 280
Converting membergroups...
Sorry, the database connection information used in the specified installation of pragmaMx cannot access the installation of SMF. This may either mean that the installation doesn't exist, or that the MySQL account used does not have permissions to access it.

Was mache ich falsch ?
« Letzte Änderung: 05 Oktober 2007, 02:06:21 von TrippleEx »

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #1 am: 05 Oktober 2007, 23:30:47 »
Ist hier niemand der Helfen kann ?

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #2 am: 05 Oktober 2007, 23:38:09 »
Bekomme auch die selben Fehler auch auf dem Online Webserver bei der Brige:


Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #3 am: 06 Oktober 2007, 00:41:38 »



Zitat von: siggi

- BITTE KEINE DOPPELTEN ODER DREIFACHEN POSTS -

« Letzte Änderung: 07 Oktober 2007, 06:21:27 von siggi »

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #4 am: 07 Oktober 2007, 02:55:23 »
Habe jetzt mal mit einem:
OR die('Fehler: '. mysql_error()); 
herausgefunden:

Converting...
Fehler: Table 'pmx.smf_members' doesn't exist

Es sagt aus das die o.g. tabelle nicht existiert, aber ich verstehe nicht wieso ?
Wo ist denn da etwas schiefgelaufen???

Offline exciting

  • ****
  • 287
  • +1/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #5 am: 07 Oktober 2007, 05:17:08 »
willst du daten aus einem bestehenden smf übernehmen, oder ne frischinstallation von smf?

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #6 am: 07 Oktober 2007, 10:30:46 »
Will sie aus einem bestehenden SMF Standalone übernehmen.

Offline exciting

  • ****
  • 287
  • +1/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #7 am: 07 Oktober 2007, 10:35:11 »
versuch es mal mit der convert.php in diesem thread

http://www.pragmamx.org/Forum-topic-21873.html


Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #8 am: 07 Oktober 2007, 12:02:06 »
Danke für den Link, aber ganau die benutze ich doch schon.


Also ich muss sagen ich bin begeistert vom PragmaMX Support Forum  :thumbup:
« Letzte Änderung: 07 Oktober 2007, 12:18:34 von TrippleEx »

Offline exciting

  • ****
  • 287
  • +1/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #9 am: 07 Oktober 2007, 12:36:47 »
mit süffisanen kommentaren wirst auch nicht weit kommen.

welche smf-version benützt du? 1.3 oder höher?

du brauchst dringend eine version 1.2, mit 1.3 bzw. 1.4 geht die bridge nicht.


das forum (smf-dateien) in modules/Forum/smf
kopiert?

« Letzte Änderung: 07 Oktober 2007, 12:50:17 von exciting »

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #10 am: 07 Oktober 2007, 12:53:40 »
SMF v 1.2.1

Ja ich habe auch bereits den Kompletten Inhalt vom Standalone SMF ins Verzeichniss  modules/Forum/smf
 kopiert.

Offline exciting

  • ****
  • 287
  • +1/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #11 am: 07 Oktober 2007, 12:57:32 »
am besten du beschreibst einfach mal selber wie du genau vorgegangen bist, evtl. sieht man dann woran es hakt.


1.2.1? du meinst 1.1.2 oder?

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #12 am: 07 Oktober 2007, 13:13:26 »
Also,

ich habe laut Anleitung:

1. Die pragmaMX auf den Webserver hochgeladen und pragmaMX installiert
2. den Inhalt des "pragmaMx-Bridge" (Port-All-Com-Fonts) /html Verzeichnisess ins Webserver /html Verzeichnis hochgeladen.

3. Das Forum Modul aktiviert. über pragmaMX Modulsteuerung.
4. den Inhalt des Standalone SMF Verzeichnisses ins /modules/Forum/smf/ kopiert.
5. Mit dem Tool "repair_settings" die Settings nach obrigem Scrrenshoot Editiert.
6. Und wenn ich dann die "convert.php" aufrufe wird nicht konvertiert sondern ich bekomme die Fehlermeldung wie oben im Screenshout !!

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #13 am: 07 Oktober 2007, 13:25:06 »
Zitat
4. den Inhalt des Standalone SMF Verzeichnisses ins /modules/Forum/smf/ kopiert.
Hallo TrippleEx,
ist dieser modules Ordner bei dir im html Ordner, also html/modules/Forum/smf/ ,sonst liegt da dein Fehler.

Offline exciting

  • ****
  • 287
  • +1/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #14 am: 07 Oktober 2007, 13:27:54 »
hmm is smf-datenbank und pragma in der gleichen datenbank?

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #15 am: 07 Oktober 2007, 13:41:39 »
Zitat
4. den Inhalt des Standalone SMF Verzeichnisses ins /modules/Forum/smf/ kopiert.
Hallo TrippleEx,
ist dieser modules Ordner bei dir im html Ordner, also html/modules/Forum/smf/ ,sonst liegt da dein Fehler.

Hi auf meinem V-Server läuft Plesk, hier gibt es im gegensatz zu Confixx kein /html Verzeichnis sondern ein /httpdoc Verzeichnis in dem das Script liegt, also /httpdoc/modules/Forum/smf/

hmm is smf-datenbank und pragma in der gleichen datenbank?

Wieso selbe Datenbank, inder Datenbank in der pragmaMx seine Tabellen erstellt bei der Installation sind keine weitern Tabellen von SMF.
« Letzte Änderung: 07 Oktober 2007, 13:59:35 von TrippleEx »

Offline exciting

  • ****
  • 287
  • +1/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #16 am: 07 Oktober 2007, 14:01:57 »
in deiner repair_settings.php im bild ganz oben hast du ja mx..._smf stehen, die dann ja gar nicht exisiert.
die wird angelegt, wenn du die methode mit einem frischen smf-bridge benützt.

du willst aber ein bestehendes smf in die bridge einbinden.

nimm einfach mal den normalen smf-prefix.

sicher aber natürlich vorher die smf-datenbank, für alle fälle.

ich hab bei meiner letzten übernahme eines bestehenden die smf-tabellen in die gleiche datenbank in der auch die pmx-tabellen sind kopiert. ob das zwingend notwendig ist, weiss ich jetzt nicht genau.
danach die werte natürlich angepasst mit repair_settings.php und das forum erst noch standalone getestet ob es auch läuft.
danach convert.php ausgeführt, und dann die bridge über smf-paketmanager installiert.
« Letzte Änderung: 07 Oktober 2007, 14:10:24 von exciting »

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #17 am: 07 Oktober 2007, 16:18:57 »
Ich habs auch schon mit dem standart Präfix probiert, ohne erfolg.

Offline exciting

  • ****
  • 287
  • +1/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #18 am: 07 Oktober 2007, 17:18:13 »
und das forum daß im modules-ordner is läuft als standalone?

Offline TrippleEx

  • **
  • 85
  • +0/-0
Re: Fehler bei SMF Standalone to pragmaMX konvetierung...
« Antwort #19 am: 07 Oktober 2007, 19:53:11 »
Ja, klar, sonst hätte ich doch gar nicht ausprobiert !!!  :puzzled: