pragmaMx Support Forum pragmaMx Support Forum

Sicherheitslücke in Coppermine, Update auf 1.4.27 ?

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
In der beliebten Coppermine Bildergalerie ist eine Sicherheitslücke bekannt geworden.
Hier die komplette Info: http://forum.coppermine-gallery.net/index.php/topic,65023.0.html

Nach erster Prüfung, kann diese Sicherheitslücke in der pragmaMx Portierung der Coppermine, unter ganz bestimmten Bedingungen, auch ausgenutzt werden. Allerdings ist es unwahrscheinlich, dass genau diese Umgebung bei einem pragmaMx User existiert...

Zur Sicherheit empfehlen wir trotzdem, folgende 2 Dinge zu tun, um die potentiellen Gefahren auszuschliessen.

  • Löschen der Datei: /modules/Gallery/image_processor.php
  • Ersetzen der Datei: /modules/Gallery/include/imageObjectIM.class.php durch die hier anghängte Version der Datei
Wenn das Modul nicht im Standardordner Gallery liegt, muss der Pfad entsprechend beachtet werden ;)


User, die noch eine ältere Coppermine-Mx, vor Version 1.4.26 einsetzen sind dringendst aufgerufen ihre Installation zu aktualisieren!!


Die beiden beschriebenen Änderungen bedeuten im Prinzip ein Update auf die Coppermine Version 1.4.27.
Hier mehr dazu: click


Die Coppermine-Mx 1.4.27 ist bereits bei den Betatestern, erscheint aber erst nach der neuen pragmaMx Version.
« Letzte Änderung: 29 Mai 2010, 13:19:59 von Andi »
schön´s Grüssle, Andi