pragmaMx Support Forum pragmaMx Support Forum

Hotfix für Spaw-Editor

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Hotfix für Spaw-Editor
« am: 15 September 2008, 15:33:41 »
Das Spaw Team hat eine potentielle Sicherheitslücke im Spaw-Editor geschlosssen und dafür ein Hotfix-Release veröffentlicht.
http://blog.solmetra.com/2008/09/10/spaw-editor-php-edition-hotfix-release/

Der Hotfix kann auch in der pragmaMx Version genz einfach eingespielt werden:

Einfach die hier beiliegende theme.class.php in den Ordner /spaw/class/ kopieren und die dort bestehende überschreiben.

Auf keinen Fall, die dort angebotene Voll-Version des Spaw-Editors 2.0.8.1 einspielen.
Die Vollversion ist nicht kompatibel zur pragmaMx Version!
Diese Version ist bereits in der Entwicklerversion von pragmaMx eingeflossen und wird demnächst mit veröffentlicht....


Also, einfach nur die /spaw/class/theme.class.php ersetzen.


PS: das gilt alles für pragmaMx 0.1.10, bzw 0.1.11(beta).
Ob das auch für ältere Versionen passt haben wir nicht getestet.


edit:
es wurde gemeldet, dass die angehängte Zip-Datei Probleme beim auspacken macht, deswegen nochmal neu und gleich auch als .rar ;)
Danke für den Hinweis  :thumbup:
« Letzte Änderung: 15 September 2008, 15:56:39 von Andi »
schön´s Grüssle, Andi