pragmaMx Support Forum pragmaMx Support Forum

Trotz fast leerem Ausgang ist kein versenden möglich

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Trotz fast leerem Ausgang ist kein versenden möglich
« am: 05 November 2007, 12:02:19 »
Hallo :)!
Ich habe nochmal eine Frage bezüglich dieses neuen PN Modules.

Ein Mitglied meinte, daß bei ihm das versenden von PNs nicht möglich ist.
Folgende Meldung erscheint immer:
Deine Box mit den gesendeten Nachrichten ist voll!
Bitte sichern und leeren!

Dabei sind nur 30 von 200 erlaubten im Ausgang.

Ich habe das gerade eben mit seinem Account getestet und es funktioniert einfach nicht.
Egal ob über den Buddy oder über das Modul selber.
Dabei ist es auch egal, ob nun der Haken bei PM im Ausgang speichern gesetzt ist oder nicht.

Dieser Fehler tritt aber nicht bei allen Mitgliedern auf.
Anscheinend nur bei diesem.

Offline Volker

  • *
  • 9
  • +0/-0
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #1 am: 06 November 2007, 15:54:19 »
Klingt wie mein Problem http://www.pragmamx.org/Forum-topic-23041.html

Viele Grüße
Volker

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #2 am: 06 November 2007, 16:35:13 »
Danke für die Hilfe, Volker :)!
Nur... irgendwie hat sich da bis jetzt noch nichts getan, oder hat man bereits eine Lösung gefunden?

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #3 am: 06 November 2007, 20:59:06 »
Hallo, ihr zwei,
ich habe bereits einiges getestet, aber ich kann euren Fehler leider nicht nachvollziehen.
Habt ihr sicher alle Dateien hochgeladen?
Wenn das nur bei einem einzigen User vorkommt, welche ID hat der und kommen bei dem irgendwelche Sonderzeichen im Usernamen vor?
Wieviele PM´s werden in der Datenbank in der Tabelle priv_msgs_send für den User angezeigt (to_user = USER ID)?
Wie ist eure PM-Begrenzung eingestellt Ein und Ausgang und ab wievielen PM´s tritt der Fehler dann auf?

Gruß Gerhard

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #4 am: 06 November 2007, 21:18:35 »
Jup! Alle Dateien wurden hochgeladen.
Sonderzeichen kommen bei dem User nicht vor.
In der Datenbanktabelle werden 21 Nachrichten angezeigt.
200 PMs sind erlaubt für Aus- und Eingang.
Der Fehler tritt laut dem User immer auf. Egal ob nun 0 oder 199 PMs (von 200 zugelassenen) in seinem Postfach sind.

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #5 am: 06 November 2007, 21:34:16 »
Der Fehler tritt laut dem User immer auf. Egal ob nun 0 oder 199 PMs (von 200 zugelassenen) in seinem Postfach sind.
Das verstehe ich jetzt nicht ganz :gruebel:
Werden die PM´s jetzt trotzdem versendet oder wie ist der sonst auf die zuerst erwähnten 30 gekommen?

Offline Volker

  • *
  • 9
  • +0/-0
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #6 am: 07 November 2007, 10:24:17 »
Bei mir sind die Dateien auch komplett.

Das Limit stand beim ersten User auf 100. Er hatte 21 im Ausgang.
Dann hat er den Ausgang gelöscht. Problem blieb bestehen. Habe das Limit auf 150 hochgesetzt. Problem behoben. Zumindest bei diesem User und bisher.
Der nächste hatte, als er Bescheid gab, schon seinen Postausgang geleert. Hab das Limit dann auf 250 hochgesetzt. Problem vorerst behoben.
In beiden Fällen konnte ich in der DB unter to_user = USER ID genau den vom User gemeldeten Stand seines Postausgangs nachvollziehen.

Ich habe versucht, das im Code nachzuvollziehen, aber meine PHP-Kenntnisse sind seeeehr begrenzt.
In der Index.php Zeile 273:
      $qry = "SELECT to_userid, Count(msg_id) FROM ${prefix}_priv_msgs_send WHERE to_userid=" . $uid . " GROUP BY to_userid;";
Prüft wohl to_userid

In der buddy.php in Zeile 170
$qry_sent = "SELECT Count(*) FROM " . $prefix . "_priv_msgs_send WHERE from_userid=" . $GLOBALS["userinfo"]["uid"] . "";

wird das Feld from_userid für die Menge der gesendeten überprüft (?).

Welcher der beiden Codes nun zuschlägt habe ich leider keine Ahnung.
 Aber wenn ich in der DB nach from_userid selektiere für den fraglichen User, bekam ich als Ergebnis in beiden Fällen Zahlen, die über dem Limit lagen.


Gruß
Volker

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #7 am: 07 November 2007, 12:21:56 »
Zitat
Werden die PM´s jetzt trotzdem versendet oder wie ist der sonst auf die zuerst erwähnten 30 gekommen?
Ich hatte vorher schon, bevor Eure Version heraußgekommen ist, so eine Erweiterung gehabt.
Die gab es irgendwo mal hier im Forum zum Download.
Deswegen auch die 30 Stück im Postausgang :).

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #8 am: 07 November 2007, 21:46:25 »
Hi Volker, danke für den Hinweis!  :thumbup:

Da stimmt wirklich was nicht, demnach müsste der genannte Fehler nur dann auftretten, wenn die User den Messenger benutzen. Kann das wer bestättigen?

Bitte die buddy.php  Zeile 170 auf
$qry_sent = "SELECT Count(*) FROM " . $prefix . "_priv_msgs_send WHERE to_userid=" . $GLOBALS["userinfo"]["uid"] . "";ändern.
Dann müsste es funktionieren.

Offline Volker

  • *
  • 9
  • +0/-0
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #9 am: 08 November 2007, 12:46:26 »
Hallo Gerhard,

ich denke, das wars. Danke.
Leider keine Ahnung, ob die User den Messenger benutzen.
*g* bei den meisten unserer User erübrigt sich auch die Frage, weil die keine Antwort wüssten oder die lauten würde: Na ich hab auf PM geklickt...

Gruß
Volker

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #10 am: 08 November 2007, 13:33:08 »
*g* bei den meisten unserer User erübrigt sich auch die Frage, weil die keine Antwort wüssten oder die lauten würde: Na ich hab auf PM geklickt...

Das ist Schade, währe sehr Interresant!
Aber es muß wohl daran liegen, da ihr "nur" zu dritt seid mit diesem Fehler :gruebel:

Gruß Gerhard

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #11 am: 08 November 2007, 13:37:20 »
Ich habe es jetzt mal abgeändert...
soll sich mein Mitglied mal damit befassen und mir bescheid geben ob es nun geht oder nicht.
Ich berichte dann :)!

Vielen Dank erstmal für Deine Hilfe, Gerhard

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #12 am: 08 November 2007, 20:16:15 »
Also das Verschicken über den Buddy funktioniert nun.
Über das Modul selber aber noch nicht.
Aber evtl. bekomme ich es selber hin :)!

Offline Volker

  • *
  • 9
  • +0/-0
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #13 am: 09 November 2007, 09:30:21 »
hm, das war's wohl doch noch nicht. gerade hat sich noch ein User gemeldet.
Die Outbox ist leer.
Kann es sein, dass noch irgendwo auf from_userid geprüft wird ?

Gruß
Volker

Nachsatz:
Ich glaube, ich hab's gefunden:
Index.php Zeile 1060
$qry_sent = "SELECT Count(*) FROM " . $prefix . "_priv_msgs_send WHERE from_userid=$uid";


Könnt Ihr das bestätigen?
« Letzte Änderung: 09 November 2007, 10:01:33 von Volker »

Offline Volker

  • *
  • 9
  • +0/-0
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #14 am: 09 November 2007, 11:13:50 »
Nachsatz:

ich habe die Zeile 1060 vorhin auf to_userid geändert.
scheint geholfen zu haben.

Der betroffene User hat mir gerade bestätigt, dass er wieder versenden kann.

Gruß
Volker

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #15 am: 10 November 2007, 09:06:02 »
Super :)!
Jetzt funktioniert es wieder :thumbup:

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #16 am: 11 November 2007, 12:36:03 »
Freut mich auch, das es jetzt bei allen funktioniert.

Den Download werde ich auch anpassen, sobald das Problem hier auch gelöst ist ;)

@Volker und Liu-Kang
Danke für Eure Hilfe :thumbup:

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #17 am: 13 November 2007, 19:23:52 »
Irrtum :puzzled:!
Es funktioniert anscheinend doch nicht.

Jetzt bekommt ein anderes Mitglied diese Meldung zum lesen.
Zitat des Mitglieds:
Zitat
Jetzt habe ich plötzlich die Nachricht bekommen, dass meine Outbox voll ist. Ja. Schön. Ich habe 9 von 200 gespeicherte Nachrichten. Und das führt natürlich dazu, dass die PM, die ich gerade beantworten wollte, einfach verschwunden ist.

Offline CanKan

  • ****
  • 280
  • +0/-2
  • Geschlecht: Männlich
  • Istanbul
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #18 am: 21 Januar 2008, 23:55:58 »
Hallo,

gibt es denn für die Fehlermeldung eine Lösung? Ich bekomme eMails von einigen Usern, die keine PMs mehr schicken können

Was muss denn geändert werden?


MfG

CanKan

Der Hund bellt, die Karawane zieht weiter.

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Trotz fast leerem Ausgang ist kein versenden möglich
« Antwort #19 am: 22 Januar 2008, 17:12:56 »
Hallo CanKan,

hast du diese Korrektur bei dir schon mal versucht. Bei den anderen dürfte es mit dieser funktionieren, da ich bis jetzt noch nichts gegenteiliges gelesen habe ;)
Aber bitte unbedingt an die Anweisung halten!

Das gelesen PIX im Postausgang ist in dieser Version noch nicht behoben, wir hoffentlich nach dem erscheinen der 0.1.10 Version behoben ;)