pragmaMx Support Forum pragmaMx Support Forum

Schwere Sicherheitslücken in "Squery 4.xx PHPNuke Module"

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Aus gegebenen Anlass weisen wir darauf hin, dass in den phpNuke-Modulen
   Squery 4.0.1  PHPNuke Module und Squery 4.5.1  PHPNuke Module
schwere Sicherheitslücken bestehen.

Über diese Lücke kann schadhafter Code auf dem Webserver ausgeführt werden.
Wie SecuriTeam™ berichtet, besteht diese Lücke in der Standallone Version.
http://www.securiteam.com/exploits/5VP0J00IAS.html

Die Dateien der Standallone Version gehören aber auch zum Lieferumfang der Nuke Module, so dass diese Schadfunktion auch in diesen Modulen funktioniert.

Ob bereits ein Fix existiert ist uns nicht bekannt.
Hierzu am besten auf der Homepage der Modulautoren erkundigen: http://phpnuke-clan.com

Wir empfehlen als Schnellfix, den kompletten Ordner "SQuery" der sich im root der nuke/pragmaMx Installation befinden zu löschen. Ob auch Schadcode in den Moduldateien selbst ist, haben wir nicht getestet. Sicherheitshalber sollte das Modul auch aus dem Modulordner gelöscht werden.

Dieses Problem betrifft auch pragmaMx und eine pragmaMx Installation wurde darüber bereits gehackt und die komplette Datenbank gelöscht.
>> Sofort handeln



EDIT:
gerade gefunden:
http://www.phpnuke-clan.com/modules.php?na...iewtopic&t=2133
Aber in den Downloadpaketen ist das Problem weiterhin vorhanden.
« Letzte Änderung: 09 Juni 2006, 18:45:20 von Andi »
schön´s Grüssle, Andi