pragmaMx Support Forum pragmaMx Support Forum

probleme mit dem center block

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline spike

  • ****
  • 420
  • +0/-1
probleme mit dem center block
« am: 08 Juni 2006, 10:36:55 »
hi, hab das update gemacht, es geht auch bisher scheinbar alles im eboard, bis auf

den center block der erscheint zwar, aber mit ner ellenlangen fehlermeldung:

Error sql_query():
qry: SELECT uname FROM _users WHERE ((user_lastvisit >= 1149754691) AND (user_stat=1) AND (user_lastmod<>'logout'))
descr: Table 'XXXXX._users' doesn't exist ( mysql 1146 )
details:

file: /blocks/block-eBoard_Center.php # line: 336, cmd: sql_query(SELECT uname FROM _users
                      WHERE ((user_last...),
file: /includes/mx_api.php # line: 806, cmd: include(SELECT uname FROM _users
                      WHERE ((user_last..., /blocks/block-eBoard_Center.php),
file: /includes/mx_system.php # line: 467, cmd: mxgetblockdata(SELECT uname FROM _users
                      WHERE ((user_last..., /blocks/block-eBoard_Center.php, Array[32]),
file: /includes/mx_system.php # line: 670, cmd: mxgetallblocks(SELECT uname FROM _users
                      WHERE ((user_last..., /blocks/block-eBoard_Center.php, Array[32], l),
file: /themes/AOM/theme.php # line: 320, cmd: blocks(SELECT uname FROM _users
                      WHERE ((user_last..., /blocks/block-eBoard_Center.php, Array[32], l, left),
file: /header.php # line: 110, cmd: themeheader(SELECT uname FROM _users
                      WHERE ((user_last..., /blocks/block-eBoard_Center.php, Array[32], l, left),
file: /modules/blank_Home/index.php # line:  33, cmd: include(SELECT uname FROM _users
                      WHERE ((user_last..., /blocks/block-eBoard_Center.php, Array[32], l, left, /header.php),
file: /index.php # line:  69, cmd: include_once(SELECT uname FROM _users
                      WHERE ((user_last..., /blocks/block-eBoard_Center.php, Array[32], l, left, /header.php, /modules/blank_Home/index.php),


Error sql_fetch_row():
descr: mysql_fetch_row(): supplied argument is not a valid MySQL result resource
details:

file: /blocks/block-eBoard_Center.php # line: 337, cmd: sql_fetch_row(false),
file: /includes/mx_api.php # line: 806, cmd: include(false, /blocks/block-eBoard_Center.php),
file: /includes/mx_system.php # line: 467, cmd: mxgetblockdata(false, /blocks/block-eBoard_Center.php, Array[32]),
file: /includes/mx_system.php # line: 670, cmd: mxgetallblocks(false, /blocks/block-eBoard_Center.php, Array[32], l),
file: /themes/AOM/theme.php # line: 320, cmd: blocks(false, /blocks/block-eBoard_Center.php, Array[32], l, left),
file: /header.php # line: 110, cmd: themeheader(false, /blocks/block-eBoard_Center.php, Array[32], l, left),
file: /modules/blank_Home/index.php # line:  33, cmd: include(false, /blocks/block-eBoard_Center.php, Array[32], l, left, /header.php),
file: /index.php # line:  69, cmd: include_once(false, /blocks/block-eBoard_Center.php, Array[32], l, left, /header.php, /modules/blank_Home/index.php),

Offline Energy-drink

  • *******
  • 1.533
  • +3/-0
  • Geschlecht: Männlich
  • Stehts zu Diensten
Re: probleme mit dem center block
« Antwort #1 am: 08 Juni 2006, 10:48:30 »
hi

das hier schon gesehen und draufgeschoben?? dort gibt es auch einen neuen Centerblock.
http://www.pragmamx.org/modules.php?name=Forum&topic=16965.msg117929#msg117929
Ich bin alt aber bezahlt.... ;-)
Ich würde ja gerne die Welt verändern,
aber Gott gibt mir den Quellcode nicht!

Offline spike

  • ****
  • 420
  • +0/-1
Re: probleme mit dem center block
« Antwort #2 am: 08 Juni 2006, 10:56:38 »
hi, habe beide fixes schon draufgespielt.
habe grad gemerkt, dass ich in den einstellungen sql fehler anzeigen aktiviert hatte.. ohne das häkchen drin wird der block zumindest normal angezeigt.. aber der fehler macht mich trotzdem stutzig

also ohne eingeschaltete sql fehler anzeigen funktion ist die anzeige normal. aber der fehler ist ja da.. also erstmal keinen stress deswegen machen, aber vielleicht hat ja dann einer ne antwort, was da noch net ganz passt

greets spike

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: probleme mit dem center block
« Antwort #3 am: 08 Juni 2006, 14:11:53 »
Moin :)

komisch, dass der Fehler nur bei dir auftaucht und bisher unentdeckt blieb.... :-X

Schau mal im Block, Zeile #76 findest du folgendes:
global $prefix, $currentlang, $eb_langincluded;
das ergänzt du wie folgt:
global $prefix, $user_prefix, $currentlang, $eb_langincluded;
schön´s Grüssle, Andi

Offline spike

  • ****
  • 420
  • +0/-1
Re: probleme mit dem center block
« Antwort #4 am: 08 Juni 2006, 14:20:37 »
super, jetzt ist auch die fehlermeldung weg.. wie gesgat, wahrscheinlich wärs mir garnicht aufgefallen wenn ich nicht ausversehen in den einstellungen n haken drin gehabt hätte bei sql fehler anzeigen. denn mit ausgeschaltetem sql fehler anzeigen lief es ja auch dann bzw die anzeige war korrekt.
aber danke für die schnelle hilfe (weiss ja nicht ob wegen diesem fehler irgendwas nicht funktionierte oder ob es einfach nur ein fehler war den man hätte getrost ignorieren können

greets spike

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: probleme mit dem center block
« Antwort #5 am: 08 Juni 2006, 16:23:01 »
Naja :)

schlimm wäre es nicht gewesen, die onlineanzeige hätte halt nir gestimmt  ;)

Nur komisch, auf meiner Entwicklungsumgebung habe ich die Einstellung immer an, da hab ich das nicht bemerkt...
pfff, egal, jetzt haben wir's ;)
schön´s Grüssle, Andi