pragmaMx Support Forum pragmaMx Support Forum

Update von eBoard, Probleme

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Update von eBoard, Probleme
« am: 05 Juni 2006, 17:07:11 »
Öhm... blöde Frage...
also ich betreibe ja das eBoard...
bei diesem mxBoard brauche ich also nur die Dateien des alten eBoards überschreiben, die install.php aufrufen und das Ding durchrattern lassen?

Das habe ich nämlich gemacht und danach waren dann keine Foren mehr zu sehen und auch die Navigationsleiste fehlte.#
Danach habe ich dann die alten Dateien wieder hochgeladen und schwupps war wieder alles da.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Update von eBoard, Probleme
« Antwort #1 am: 05 Juni 2006, 17:23:09 »
Moin :)

die install.php braucht man nicht aufrufen, an der DB hat sich nichts geändert.

Ansonsten, komisches Problem.
Hatten wir bisher noch nicht, müss ma guggen ;)
schön´s Grüssle, Andi

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #2 am: 05 Juni 2006, 17:25:34 »
Soll ich Dir die Zugangsdaten geben?

Offline Jay-E

  • *****
  • 573
  • +0/-1
  • Geschlecht: Männlich
  • Aramäer
Re: Update von eBoard, Probleme
« Antwort #3 am: 05 Juni 2006, 17:45:46 »
Kannst du bitte nochmals überprüfen ob der download link bei dir geht???

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #4 am: 05 Juni 2006, 17:46:26 »
Nochwas...
sobald ich die Dateien hochgeladen habe und testweise als normaler Nutzer auf die normale Startseite gehe, erscheint:
Zitat
Not in mxBoard...

Offline Liu-Kang

  • *****
  • 700
  • +0/-3
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #5 am: 05 Juni 2006, 17:51:10 »
@Jay-E:
Nein... bei mir geht er auch nicht mehr.

Offline Jay-E

  • *****
  • 573
  • +0/-1
  • Geschlecht: Männlich
  • Aramäer
Re: Update von eBoard, Probleme
« Antwort #6 am: 05 Juni 2006, 17:52:32 »
gut dann war das wohl einer der Admins, aufgrund deiner Probleme, testen die das ding wohl nochmal :D .......

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #7 am: 05 Juni 2006, 18:06:41 »
Soll ich Dir die Zugangsdaten geben?

Ja, wäre nicht schlecht.
Da dieses Problem während den Betatests nicht vorgekommen ist, würde mich das interessieren...

Heute komme ich da aber nicht mehr dazu.


Der Download müsste jetzt wieder gehen, hatte mich vorhin verklickt....
schön´s Grüssle, Andi

Offline soeren

  • *
  • 6
  • +0/-0
Re: Update von eBoard, Probleme
« Antwort #8 am: 05 Juni 2006, 19:14:52 »
hi, bei mir sind auch alle foren verschwunden, aber in der db steht noch alles drin !!!

Offline Jay-E

  • *****
  • 573
  • +0/-1
  • Geschlecht: Männlich
  • Aramäer
Re: Update von eBoard, Probleme
« Antwort #9 am: 05 Juni 2006, 19:32:08 »
gleiche auch bei mir!!!

Offline FrankySZ

  • *******
  • 1.462
  • +5/-0
  • Geschlecht: Männlich
  • Pragmatizer
Re: Update von eBoard, Probleme
« Antwort #10 am: 05 Juni 2006, 19:43:53 »

Hi @ll,

bitte mal in der settings.php eurer eBoardinstallation schauen

in Zeile 24 sollte wenn eure Datenbanktables mit _eBoard_  mit nem grossem B geschrieben werden

geaendert werden von

$tablepre = $prefix . '_eboard_';

$tablepre = $prefix . '_eBoard_';

danach sind alle Foren wieder da ...



greets Franky

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #11 am: 05 Juni 2006, 19:56:20 »
Moin :)

muss feststellen, das wir eine extra Update Version für das eBoard bereitstellen müssen, damit die settings.php nicht mehr überschrieben wird.
schön´s Grüssle, Andi

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #12 am: 05 Juni 2006, 21:10:22 »
So, im Downloadbereich findet sich jetzt auch eine Updateversion für das eBoard.  :thumbup:

http://www.pragmamx.org/Downloads-d_op-viewdownload-cid-88.html
schön´s Grüssle, Andi

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #13 am: 06 Juni 2006, 07:23:16 »
Moin :)

So, Problem bei Liu-Kang ist gelöst.
Es lag,, so wie schon FrankySz geschrieben hatte, an der überschriebenen Settings.php.
Sorry, da hatte ich beim Downlodpaket zusammenpacken, nicht dran gedacht....

ich habe das alte eBoard so belassen wie es ist, das neue Modul liegt im Ordner "eBoard NEU", mit der passenden settings.php. Wenn du umstellen willst, brauchst du nur die beiden Ordner umzubenennen. :)

Nochwas...
sobald ich die Dateien hochgeladen habe und testweise als normaler Nutzer auf die normale Startseite gehe, erscheint:
Zitat
Not in mxBoard...
Jop, das liegt an den "alten" eBoard Blöcken. Die Blöcke includen eine Datei im eBoard Ordner, die eine bestimmte Konstante voraussetzt. Wenn du die alten Blöcke weiter verwenden willst, dann muss folgende Codezeile im Block eingefügt werden:

if (!defined("MXB_INIT")) define('MXB_INIT', true);
schön´s Grüssle, Andi

Offline smartmusic

  • *******
  • 1.269
  • +1/-0
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #14 am: 06 Juni 2006, 11:26:19 »
bekomme diese fehler meldung im forum

Notice: Use of undefined constant prefix - assumed 'prefix' in /var/www/vhosts/gecealem.de/httpdocs/modules/eBoard/settings.php on line 27

Notice: Use of undefined constant _NEWSARTICLES - assumed '_NEWSARTICLES' in /var/www/vhosts/gecealem.de/httpdocs/includes/my_header.php on line 37

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #15 am: 06 Juni 2006, 13:22:33 »
http://www.pragmamx.org/Content-pa-showpage-pid-48.html#brule_6  :mad:
Zitat
Folgende Regel ist dabei hilfreich: "Neue Frage – neues Thema"

Hi :)

einmal im Control-Panel die Einstellungen abspeichern, dann sollte die erste Meldung verschwunden sein.

Dann in der header.php des mxBoards, folgende 2 vergessenen Zeilen entfernen:

// TODO:
error_reporting(E_ALL);

schön´s Grüssle, Andi

Offline smartmusic

  • *******
  • 1.269
  • +1/-0
  • Geschlecht: Männlich
Re: Update von eBoard, Probleme
« Antwort #16 am: 06 Juni 2006, 13:28:50 »
alles klar andi...danke :thumbup: