Aw: Update/Upgrade von pragmaMx 2.x auf PHP 8.0/8.1 bei Ionos

Begonnen von redlion, 22 September 2022, 12:52:42

⏪ vorheriges - nächstes ⏩

0 Mitglieder und 1 Gast betrachten dieses Thema.

redlion

Hallo
Patch 2.82 habe ich installiert, aber auf IONOS funktioniert php 8.0 php 8.1
nicht, laut IONOS Support liegt der Fehler in der Software.
Index Datei wird nicht angezeigt bleibt leer.
PragmaMx funktioniert aber weiterhin unter php 7.4
Support für 7.4 wird aber bis Jahresende eingestellt.
Ich möchte mich hier aber für PragmaMx bedanken ich finde die Software sehr
gut.

 :)  :)

Olaf

erstmal wilkommen im Forum  :drinks:

wir haben unter einer Version PHP 8.010 und 8.1.10 getestet, ohne Probleme..... deshalb :

1. Update auf pmx 2.8.1/2 (Patch auch)
2. Setup durchführen
3. unter PHP 7.4
  - Debugmodus für Administratoren einschalten
  - alle alten Zusatzmodule auf neueste Version aktualisieren
  - alle nicht benötigten Blöcke/Module/Plugins deaktivieren
4. Dann nochmal auf PHP8.ff umschalten und die eventuellen Fehler notieren, hier posten.

Dann kommen wir der Sache hoffentlich näher.....

PS: und Danke für das Lob  :pardon:
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

redlion

Wird auf Dashboard angezeigt php7.4.3

CMS-Version:
pragmaMx 2.8.2.628 (2022-09-20)
PHP-Version:
7.4.30   (PHP-Info)
MySQL-Version:
5.7.38-log
Server-Version:
Apache
jQuery-Version:
1.11.1
jQueryUI-Version:
1.10.2

Nach Umstellung auf 8.0.23

CMS-Version:
pragmaMx 2.8.2.628 (2022-09-20)
PHP-Version:
8.0.23   (PHP-Info)
MySQL-Version:
5.7.38-log
Server-Version:
Apache
jQuery-Version:
1.11.1
jQueryUI-Version:
1.10.2

Nach dem Ausloggen erscheint nur eine leere Seite.
Debug Modus funktioniert aber weiterhin auch unter PHP 8.0/8.1

redlion

Nach Umstellung auf PHP 8.0 wird beim ausloggen aus dem Debug-Modus die Index.php nicht geladen, Seite bleibt leer bzw, weiß.
Debug Modus kann aber weiterhin über admin.php aufgerufen werden und Seite funktioniert auch dann im Startmodus, nur nach dem Ausloggen besteht das Problem das Index.php nicht angezeigt wird, es kommt aber keine Fehlermeldung im Browser.
Frage: Kann der Fehler in der Index.php liegen?


Olaf

ich konnte im Moment den Fehler auf das default-pmx-Theme einschränken. Bitte versuche mal ein anderes Theme
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

redlion

Hallo

Habe verschiedene Themes ausprobiert ohne Erfolg.

redlion

Es funktionieren keine Themes nach der Umstellung auf Php 8.0, aber warum funktioniert die Seite mit allen Modulen und Blöcken im Debug Modus?

Olaf

da war doch noch mehr ... :pardon:
ich habe mal ein Patch zusammen gestellt. (Anlage)

Das Update über eine pmx V2.8.2-Installation drüber kopieren,
- darauf achten, das alles überschrieben wird
- im Ordner 'setup" die htaccess löschen
- Setup ausführen
- Setup dann durchklicken bis zum Adminbereich.
- dann sollte es gehen

Bitte mal Testen und Rückmeldung. Danke.
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

redlion

Ich habe Patch installiert, bekomme beim Setup Fehler "Error: the language-folder (/language) is missing!"

Olaf

an welcher Stelle kommt diese Meldung.
Wenn du ein pmx 2.8.2 komplett installiert hast und das Patch drüber packst, sind alle Language-Ordner vorhanden...  :gruebel:
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

redlion

#10
ja language Verzeichnis vorhanden mit folgenden Einträgen:

/language/to-do.php
/language/lang-turkish.php
/language/lang-german_du.php
/language/lang-german.php
language/lang-french.php
/language/lang-english.php
/language/lang-danish.php
/language/index.html
/language/.htaccess
/language/admin
/language/custom
/language/credits

Olaf

wenn es dir keine Probleme bereitet, dann gib mir mal per PN einen FTP und einen Adminzugang zu der Seite, dann schau ich mir das mal an.
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

redlion

Kann ich nicht da noch andere Daten vorhanden sind, wenn es mit PHP 8.0/8.1
nicht funktioniert bleib ich erstmals bei PHP 7.4 und werde dann wohl oder übel
wenn die Version nicht mehr unterstützt wird den kostenpflichtigen Support für ältere
PHP Versionen von Ionos in Anspruch nehmen müssen.
Ich möchte ja weiterhin PragmaMx verwenden da es mir gut gefällt und es gut zu händeln ist.
Ich habe früher mal mit Nuke angefangen das auch gut war, Support wurde aber vor langer Zeit
wie du sicher weißt eingestellt und so bin auf der Suche nach neuer Software zu PragmaMx gekommen.
Danke für die Unterstützung und hoffentlich bleibt PragmaMx noch lange erhalten.

Mit freundlichen Grüßen

Redlion

Olaf

ok, kann ich verstehen
es hätte uns nur geholfen, den Fehler zu analysieren und ggf. zu beheben. Übrigens, die Daten sind bei uns sicher und werden nach jedem Thema gelöscht.
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

redlion

#14
Ich habe PragmaMx 2.8.1 nochmals installiert und wollte dann den Patch 2.8.2 installieren bekomme aber die Meldung: pragmaMx-Setup is locked.

Sorry Fehler von mir hatte .htaccess nicht gelöscht.

redlion


Fokuna2

Zitat von: redlion am 27 September 2022, 12:07:00Ich habe PragmaMx 2.8.1 nochmals installiert und wollte dann den Patch 2.8.2 installieren bekomme aber die Meldung: pragmaMx-Setup is locked.

Sorry Fehler von mir hatte .htaccess nicht gelöscht.
Wo ist diese überhaupt versteckt?, ich habe eine Modewrite .htaccess gelöscht, aber Setup ist immer noch gesperrt / locked
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

Olaf

bei richtiger Installation wird der SETUP-Ordner erstens durch einen .htaccess gesperrt und ausserdem die index.php umbenannt.
Wenn man nu eine neue Installation machen will, so muss man die .htaccess in dem Setup-Ordner löschen und die index.phpXXXXXXXX wieder in index.php umbenennen.

Das Thema ist auch schon mal in den FAQ beantwortet.... https://www.pragmamx.org/FAQ-Installation-category-17.html
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Fokuna2

Zitat von: Olaf am 30 September 2022, 07:47:33bei richtiger Installation wird der SETUP-Ordner erstens durch einen .htaccess gesperrt und ausserdem die index.php umbenannt.
Wenn man nu eine neue Installation machen will, so muss man die .htaccess in dem Setup-Ordner löschen und die index.phpXXXXXXXX wieder in index.php umbenennen.

Das Thema ist auch schon mal in den FAQ beantwortet.... https://www.pragmamx.org/FAQ-Installation-category-17.html

Danke
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x