PMX 2.8.1 Installation - Testung

Begonnen von Fokuna2, 18 September 2022, 14:49:20

⏪ vorheriges - nächstes ⏩

0 Mitglieder und 1 Gast betrachten dieses Thema.

Fokuna2

Ich wollte die neue Versionen jetzt erstmal ausprobieren, und haben diese erst einmalig unter den Ordner fü Testzwecke installiert.
Leider komme ich nicht weiter, als auf die Setup Startseite von PMX 2.8.1, danach erscheint statt das Formular, für die Eingabe der Server Daten. eine Weisse Seite.

Woran kann das den genau liegen?
Liegt es eventuell an einem Themen, weil ich auf der Blanko Seite, keine Meldungen bekommen ?
Kann es es an der Datei:option_.php, liegen ?
Diese wird nämlich nicht gefunden, sie sollte eigentlich im Setup Ordner liegen.
Im Ordner ist die Datei leider auch nicht vorhanden, nur im Ordner Setup / includes  sind ähnliche php Dateien zu finden wie option_new.php oder option_update.php

ich benutzte
mysql:8.0.28-19
php: PHP Version 8.0.23-udmedia

der Link führt leider zu der erwähnte weisse Seite, eine lehre Index Seite.

http://w.fokuna.de/setup/index.php?op=check&slang=german&mxsetupid=20220918024718
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

Olaf

ja, da ist mir was durchgerutscht...
im Anhang mal das korrigierte Setup.
Bitte den kopletten Ordner "Setup" aus dem ZIP im Anhang über den alten Ordner drüberkopieren. Darauf achten, das alles überschrieben wird.

Melde mal zurück, obs es bei dir klappt.
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Fokuna2

Danke es ging schon ein gutes Stück weiter.
Nur komme ich folgende Meldung:


Zitatmysql /var/www/ud20_135/html/W2/setup/includes/mx_db_mysqli.php 381 Access denied; you need (at least one of) the SUPER, SYSTEM_VARIABLES_ADMIN or SESSION_VARIABLES_ADMIN privilege(s) for this operation 1227 SET names 'latin1', character set 'latin1', character_set_results = 'latin1', character_set_client = 'latin1', character_set_connection = 'latin1', character_set_database = 'latin1', character_set_server = 'latin1'


und kann leider keine Admin anlegen.

und auf der Startseite gibt es auch folgende  Meldung:

ZitatFatal error: Uncaught exception:
array_merge(): Argument #2 must be of type array, bool given (code: 0)
in includes/classes/Header.php on line 680

Gute nacht
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

Olaf

da liegt das Problem wieder bei den Rechten auf deinem MySQl Server. Ich schau mir das aber mal an. Das 2. Basiert auf dem 1. Problem....
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Fokuna2

ist den mein Provider so speziell ?
das er Einstellungen hat, die  anscheinend nicht normal sind,
sonst wären diese doch in dem ganzen verfahren beim Programmieren berücksichtigt oder ?
Ich verstehe davon nicht viel.
-
Er schmeisst quasi die vorvorletzte niedriger PHP version, am ende des Jahres raus,
weil sie nicht mehr sicher wäre.
 Er bietet mindesten immer 2 Versionen an php 7.4. wird bis zum 28.11.22 Sicherheitsupdate bekommen. Er empfiehlt jetzt schon php 8.0.x bis zum  26.11.23 ein Sicherheitsupdate bekommen  .
Php 8.1.x wird bis zum 26.11.24 ein Sicherheitsupdate bekommen
das sind seine eigene Angaben.

Mit freundliche Grüße

Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

Olaf

es gibt genug Scripts/Webseiten, welche mit PHP 7 schon nicht mehr funktionieren, geschweige mit PHP8.ff, aber dennoch sicher sind und ihre Daseinsberechtigung haben. Siehe z.Bsp. die Coppermine-Gallery, die wir früher gebridgt hatten. Diese würde also auf deinem Server nie mehr laufen können.  Ich weiß nicht, warum dein Hoster nicht, wie die meisten anderen auch, noch zumindestens eine ältere Version von PHP (und MySQL) anbieten. Mit Sicherheitsbedenken hat das wenig zu tun..... Du wechselst zu Hause auch nicht jedes Jahr dein Türschloss aus, nur weil es was neues gibt auf dem Markt.
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Olaf

g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Fokuna2

Hallo Olaf,
Vielen Dank, für die schnelle Reaktion und der Beta Version-


Zitat von: Olaf am 20 September 2022, 10:36:11es gibt jetzt auch einen kleinen Patch für die Problematiken
https://www.pragmamx.org/Downloads-pragmaMx-zwei-dot-acht-dot-zwei-Patch-view-1091.html
Das Beta System bringt immerhin das PMX schon mal zum laufen,  jetzt verhindert das Zusatz Module SiriusGallery 2.9 das Einrichten des PMX Version 2.8.2.628

Es ist immer noch die (un)geliebte Datenbankproblemen in der Zeile 688 lt. der Meldungen.

Wenn ich das Module installieren will, wird anscheinend Eintrag in der mx_db_mysqli Datei erstellt,
aber die besagte Tabelle wird aber nicht gefunden und das ganze System ist nicht mehr aufrufbar.
Lösche ich das Module, ist das CMS wieder in Ordnung.

Ich habe den Thread hier reingestellt, weil es im Prinzip immer noch mit den gleichen Installation Problemen zu tu tun hat, nur anscheinend jetzt an einer andren stellen.
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

Olaf

lade dir das Paket noch mal neu von hier runter. Da ist ein Fehler im Paket der SG gewesen......

https://www.pragmamx.org/modules.php?name=Downloads&op=view&lid=1087
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Fokuna2

Zitat von: Olaf am 21 September 2022, 07:16:53lade dir das Paket noch mal neu von hier runter. Da ist ein Fehler im Paket der SG gewesen......

https://www.pragmamx.org/modules.php?name=Downloads&op=view&lid=1087
dies
hat leider nichts gebracht folgende Fehlermeldungen kommen immer noch vor:
Es sind Probleme bei der Seitenerstellung aufgetreten.

Fatal error: Uncaught exception:
Table 'usr_ud20_135_3.mx54b63cd_tmgallery_config' doesn't exist (code: 1146)
in includes/mx_db_mysqli.php on line 688
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

Olaf

tausche mal bitte die admin.php in dem Modul SiriusGallery aus. und teste noch mal....
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Fokuna2

Zitat von: Olaf am 21 September 2022, 14:00:13tausche mal bitte die admin.php in dem Modul SiriusGallery aus. und teste noch mal....

leider nein.

Ich habe das Module nochmal neu Installiert, nach eueren Anleitungen, auch einige Cash Leerungen vollzogen.
nun kommt diese Fehlermeldung zustanden:

ZitatEs sind Probleme bei der Seitenerstellung aufgetreten.

Fatal error: Uncaught exception:
Call to undefined function setupGetTables() (code: 0)
in modules/SiriusGallery/inc/install.tabledef.sg.php on line 23
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

Fokuna2

Ich haben meine Antwort Beitrag, in einem anderen Thread geschrieben.
wo essen besser hin passt.

hier geht es weiter
Mit freundlichen Grüßen
Thomas
Neue Daten:
Mysql: 8.0.28-19
PHP-Version: 7.4 ->8.0.x

titoun

Hello  :au revoir:

Thanks for the new version PragmaMx

There is a problem with a tab myaccount


for language file module Documents line 397

replace
langdefine("_DOCS_MYLAST","lesn %s derniers articles");by
langdefine("_DOCS_MYLAST","les %s derniers articles");

See you soon




Olaf

thanks  :thumbup:
noted  :mail1:
fixed in next Revision
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!