pragmaMx Support Forum pragmaMx Support Forum

Weiße Seite(n) nach Update auf 2.7.1/2

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Weiße Seite(n) nach Update auf 2.7.1/2
« am: 28 Februar 2022, 12:01:14 »
Hello,
habe ein Update auf 2.7.1 (dann auf 2.7.2) gemacht. wegen der PHP 8.0 Unterstützung. (brauch ich für ein anderes Script auf der Seite (admidio))

Nach auskommentieren der Zeile 177 in der mx_baseconfig kommt für den Adminbereich nur eine weiße Seite.
Für die Startseite ein http Error 500.

Bitte um Tips
Danke :-)

Offline Olaf

  • ******
  • 2.114
  • +4/-0
  • Geschlecht: Männlich
    • TECMU
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #1 am: 28 Februar 2022, 12:37:41 »
bei einem Normalen System pmx 2.7.x sollte das nicht passieren. Ein ERROR 500 ist aber auch ein Server-Fehler !!
Ansonsten bitte mal checken, ob alle Dateien wirklich überschrieben sind und das keine anderen Skrips im System aktiv sind. Und auf PHP >8.0.11 habe ich noch nicht getestet.
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #2 am: 28 Februar 2022, 12:47:48 »
PHP 8.0.11?
Ich hab beim world4you nur die Auswahl 8.0 oder 8.1
Bin jetzt zurück auf 7.4 mit selben Fehlerbild.

Dateien werden beim Transfer fix überschrieben. Zumindest ist es in WinSCP so eingestellt (grad nochmal kontrolliert)

Das Error 500.....vor dem Update hat die Seite noch funktioniert ;-)

Edit: Das Setup ist auch klaglos durchgelaufen

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #3 am: 28 Februar 2022, 13:16:48 »
Ich habe eine Fehlermeldung im Log für einen user...... siehe Screenshot.
Das was verpixelt ist ist aber nicht der User, sondern hier steht das Passwort drin. Und bei Passwort steht "NO"

Trotzdem keine Fehlermeldung beim Update.


Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #4 am: 28 Februar 2022, 16:07:11 »
Niemand eine Idee dazu?

Offline Olaf

  • ******
  • 2.114
  • +4/-0
  • Geschlecht: Männlich
    • TECMU
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #5 am: 28 Februar 2022, 16:43:22 »
auf die Schnelle nicht
V2.7.1/2 läuft eigentlich stabil unter PHP 8.0
ich denke, da ist iregend eine Datei nicht i.O.
nach der Fehlermeldung... überprüfe mal die DB-Angaben
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #6 am: 28 Februar 2022, 17:10:07 »
Im config.php ist alles korrekt.
Habe auch schon das File aus dem Backup hergenommen.

Wo kann ich noch nachschauen?

Offline Nouvelle

  • *****
  • 84
  • +1/-0
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #7 am: 28 Februar 2022, 18:57:12 »
Als erstes eine DB-Backup anlegen!

Würde sagen: du hast keinen Zugang mehr auf deine Datenbank
* ist deine Datenbank nicht "localhost" - dann solltest du eine IP und nicht eine URL angeben
* Bei einigen Datenbanken akzeptieren sie im Passwort auch keine Sonderzeichen (#?$&) - neues Passwort kannst du bei deinem Webhoster eingeben.
Kein Support über PN, Mail !
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #8 am: 28 Februar 2022, 19:05:23 »
Als erstes eine DB-Backup anlegen!

Würde sagen: du hast keinen Zugang mehr auf deine Datenbank
* ist deine Datenbank nicht "localhost" - dann solltest du eine IP und nicht eine URL angeben
* Bei einigen Datenbanken akzeptieren sie im Passwort auch keine Sonderzeichen (#?$&) - neues Passwort kannst du bei deinem Webhoster eingeben.

Danke für den Versuch :-)
Die Datenbank ist localhost und im Passwort sind auch keine Sonderzeichen (seit 10 Jahren) ;-)
Vor dem Update lief die Seite ja klaglos.
Sollte jetzt der Zugriff oder der Pfad zur DB nicht mehr funktionieren muss sich ja am System was geändert haben

Offline Nouvelle

  • *****
  • 84
  • +1/-0
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #9 am: 28 Februar 2022, 19:30:22 »
Du hast keine Berechtigung:

* Schau nochmal in deine config.php
dbhost, dbname, dbuname, dbpass, prefix, user_prefix
Sorry, auch wenn du schon geschaut hast, schau nochmal. vergleich die Daten mit deiner Datenbank - stimmt das wirklich?

# Der Error kann auch auftreten, wenn
* die Berechtigungen bei wichtigen Dateien nicht korrekt gesetzt sind
* PHP-Timeout: Das Skript versucht auf eine externe Ressource zuzugreifen und erfährt dabei ein Timeout
* PHP-Memory-Limit: Ein Prozess überschreitet den Arbeitsspeicher und kann deshalb nicht korrekt ausgeführt werden

Vielleicht fällt dir dazu ja was ein ...
Kein Support über PN, Mail !
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #10 am: 28 Februar 2022, 19:41:18 »
Du hast keine Berechtigung:

* Schau nochmal in deine config.php
dbhost, dbname, dbuname, dbpass, prefix, user_prefix
Sorry, auch wenn du schon geschaut hast, schau nochmal. vergleich die Daten mit deiner Datenbank - stimmt das wirklich?


OK, habe ich nochmal geprüft und mit den Einträgen im Backup verglichen. Passt alles


# Der Error kann auch auftreten, wenn
* die Berechtigungen bei wichtigen Dateien nicht korrekt gesetzt sind
* PHP-Timeout: Das Skript versucht auf eine externe Ressource zuzugreifen und erfährt dabei ein Timeout
* PHP-Memory-Limit: Ein Prozess überschreitet den Arbeitsspeicher und kann deshalb nicht korrekt ausgeführt werden

Vielleicht fällt dir dazu ja was ein ...

Gibts eine Liste mit den Berechtigungen zum Vergleichen? Vielleicht ist ja da was beim Update schief gegangen

Für einen PHP Speicher Error sollte denke ich eine entsprechende Meldung kommen.

Error 500 besagt schon das auf eine DB kein Zugriff möglich ist, da hast du schon recht.
Aber warum plötzlich nach dem Update?

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #11 am: 28 Februar 2022, 23:20:40 »
bei einem Normalen System pmx 2.7.x sollte das nicht passieren. Ein ERROR 500 ist aber auch ein Server-Fehler !!
Ansonsten bitte mal checken, ob alle Dateien wirklich überschrieben sind und das keine anderen Skrips im System aktiv sind. Und auf PHP >8.0.11 habe ich noch nicht getestet.

@Olaf
ein kleiner Zwischenerfolg hat sich eingestellt.
Nachdem ich alles was ich mir so vorstellen konnte versucht habe, habe ich aus Verzweiflung das Theme direkt in der DB auf default-pmx gestellt und siehe da, die Seite wird nun angezeigt (wenn auch nicht so wie ich das hatte ;-))

Bei der Adminseite funktioniert das leider nicht. Habe auch das Admintheme auf admin-pmx umgestellt. Das was sich verändert hat ist die Farbe. Die Seite ist nicht mehr weiß sondern dunkelgrau.

Hast du, mit diesen Informationen, einen Idee wie ich das nun hinbekomme?

Danke

Offline Olaf

  • ******
  • 2.114
  • +4/-0
  • Geschlecht: Männlich
    • TECMU
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #12 am: 01 März 2022, 06:57:04 »
Zitat
Gibts eine Liste mit den Berechtigungen zum Vergleichen? Vielleicht ist ja da was beim Update schief gegangen
guggst du hier : https://www.pragmamx.org/Documents-Handbuch-pragmaMx-Page-CHMODs-auf-dem-ServerWebspace-Id-115.html

Hast dur irgendein altes Modul/Block im Einsatz?
Welche PHP-Version hattest du vorher im Einsatz?
Gibt es Log-Einträge auf "dynadata/logfiles"?

Is schon verwirrend, da das standard-System eigentlich problemlos läuft.

alternativ schick mir mal einen FTP-Zugang zu deiner Seite per PN
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #13 am: 01 März 2022, 08:03:46 »


alternativ schick mir mal einen FTP-Zugang zu deiner Seite per PN

Sehr gerne, ist unterwegs
Vielen Dank

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #14 am: 04 März 2022, 01:04:39 »
@Olaf

Danke für deine Unterstützung und Tipps.
Habe es jetzt hinbekommen. Seite läuft fehlerfrei auf PHP 7.4 (alte Module entfernt, aktuelle Module upgedated)

Nutze nun das Theme "default-pmx".
Was mir dabei fehlt sind die Banner. Unterstützt das Theme Banner im Header nicht?

Danke :-)

Offline Olaf

  • ******
  • 2.114
  • +4/-0
  • Geschlecht: Männlich
    • TECMU
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #15 am: 04 März 2022, 07:11:56 »
in den Theme gibt es eine Datei theme.settings.php für alle Einstellungen des Themes
ab der Zeile 121 ff. kann man die Banner einstellen.
g

Olaf

Kein Support über PN, Mail etc.!
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Offline xels

  • ***
  • 125
  • +0/-1
  • Geschlecht: Männlich
Re: Weiße Seite(n) nach Update auf 2.7.1/2
« Antwort #16 am: 04 März 2022, 08:05:11 »
in den Theme gibt es eine Datei theme.settings.php für alle Einstellungen des Themes
ab der Zeile 121 ff. kann man die Banner einstellen.

Danke :-)