pragmaMx Support Forum pragmaMx Support Forum

Nach update auf 2.4 wysiwig-Probleme

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline raideg

  • **
  • 35
  • +0/-1
  • Geschlecht: Männlich
Nach update auf 2.4 wysiwig-Probleme
« am: 14 Oktober 2017, 08:00:43 »
Nachdem ich auf drei verschiedenen Seiten die Version von 2.3 auf 2.4 geupdatet habe, gibts probs mit dem wysiwig-Editor.
Auf einer Seite kann man plötzlich zwischen ckeditor, spaw und tinymce wählen, auf den anderen beiden wie gehabt nur zwischen ckeditor und tinymce.
Was aber alle drei nicht haben - im ckeditor gibt es keine Möglichkeiten mehr Dateien hochzuladen, es gehen nur die *-Eigenschaften auf.
Das uploaden funktioniert nur bei tinymce.

Ich könnte mir ja noch behelfen, allerdings schreiben da auch Leute, die nicht so firm in diesen Dingen sind.
Sollte ich mal die Vorgänger Dateien des Editors drüberbügeln oder gibt es eine sonstige Lösung des Problems?

Offline TerraProject

  • ******
  • 1.774
  • +2/-0
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #1 am: 14 Oktober 2017, 10:21:34 »
auf welche Version hast du das Update gemacht ?
gestern haben wir gerade ein Bugfix V2.4.2 veröffentlicht
g

Olaf
...:::

Kein Support über PN, Mail !
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!


Offline raideg

  • **
  • 35
  • +0/-1
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #2 am: 14 Oktober 2017, 13:09:12 »
Von Version 2.4.0. vom 02.09.17 auf Version 2.4.2.431
Habe es erst heute Nacht runtergeladen und die Seiten wie gewohnt auf die neue Version geupdatet.
Mit der Version vom 2.Sept. lief noch alles normal.

P.S. Sehe gerade, Ihr habt am Freitag auch noch eine Update-Datei bereitgestellt.
Habe ich übersehen, da auch nicht mehr gewohnt, da ihr ja im Gegensatz zu früher immer nur Vollversionen zum Update bereitstellt.

Glaubst Du es bringt etwas nur die Updates nochmal raufzuladen?

Offline raideg

  • **
  • 35
  • +0/-1
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #3 am: 14 Oktober 2017, 13:30:02 »
So, habe diese Updates auf meine eigene Hompage hochgeladen und getestet.
Nun habe ich dort auch 3 Auswahlmöglichkeiten für wysiwig-Editor (ck, spaw und tiny) und immer noch keine Bilder-Uploadmöglichkeit ausser bei Tiny.

Debug gibt folgende Meldungen raus:
pragmaMx notice:
undefined property 'deactivated' in includes/classes/Language.php line 288
in includes/classes/Config.php on line 191

PHP Run-time warning:
in_array() expects parameter 2 to be array, boolean given
in includes/classes/Language.php on line 299

pragmaMx notice:
undefined property 'deactivated' in includes/classes/Hook.php line 182
in includes/classes/Config.php on line 191

PHP Run-time warning:
in_array() expects parameter 2 to be array, boolean given
in includes/classes/Hook.php on line 194


Allerdings keine Ahnung ob und wie lange die schon da sind, da im Normalbetrieb die Debug-Einstellung aus ist.

Offline raideg

  • **
  • 35
  • +0/-1
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #4 am: 15 Oktober 2017, 01:34:22 »
Zur Info:
Habe im /includes den wysiwig-Ordner durch den der Vorgängerversion ersetzt und es funktioniert wieder alles.

Offline Fokuna2

  • ****
  • 384
  • +0/-38
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #5 am: 15 Oktober 2017, 18:32:20 »
Zur Info:
Habe im /includes den wysiwig-Ordner durch den der Vorgängerversion ersetzt und es funktioniert wieder alles.

Jetzt bin ich neugierig und möchte von Ihnen gerne wissen, welche Mysql Version bei Ihn läuft? denn ich habe leider immer noch Probleme  mit der mysql 5.7x Datenbank.
Das PMX 2.4.34x läuft nicht nicht 100 % Prozente eine Tabelle werden anscheinend nicht erstellt. oder nicht nach den verlangten Format.


Mit freundlichen Grüßen
Schuberth
neue Daten:
mysql: 5.7.19-17-log
libmysql - mysqlnd 5.0.12-devPHP-Erweiterung: mysqlPHP-Version: 7.1.10-udmediaServer-Zeichensatz: UTF-8 Unicode (utf8)

Offline raideg

  • **
  • 35
  • +0/-1
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #6 am: 15 Oktober 2017, 23:45:31 »
PHP-Version:
5.5.38-nmm3

MySQL-Version:
5.7.15-nmm5-log

Auf All-inkl.com

P.S zwei andere Seiten laufen dort mit PHP-Version: 7.0.20-nmm1 und der gleichen MySQL-Version.
Bis auf das aktuelle Prob mit dem neuen Wysiwig-Editor läuft alles andere prima.
« Letzte Änderung: 15 Oktober 2017, 23:50:06 von raideg »

Offline Biker

  • *******
  • 1.596
  • +4/-29
  • Geschlecht: Männlich
    • Biker Unity - since 2002
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #7 am: 27 Oktober 2017, 19:02:12 »
Ich habe gerade meine Seiten auf 2.4.2.448 (2017-10-17) upgedatet.

Der Bild-Upload existiert bei mir nur noch beim tinymce. (Hinter Quelle auf das Symbol)
Beim ckeditor und spaw gibt es keine Uploadmöglichkeit mehr.

Ich habe PHP 5.6.31, weil mit PHP 7.0 die Webseite nicht mehr angezeigt wird. Hatte es auf 7.0 getestet, kam nur nich eine weiße Seite.....daher wieder 5.6.31
« Letzte Änderung: 27 Oktober 2017, 19:09:53 von Biker »
Schmerz ist Schwäche, die den Körper verlässt!

Offline TerraProject

  • ******
  • 1.774
  • +2/-0
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #8 am: 11 November 2017, 09:54:18 »
wir sind an dem Editorproblem dran.....

im Notfalle erstmal aus dem Backup (sollte ja immer vorhanden sein)
aus dem Ordner /includes den wysiwig-Ordner durch den der Vorgängerversion ersetzen, wie oben schon erwähnt.
g

Olaf
...:::

Kein Support über PN, Mail !
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!


Offline TerraProject

  • ******
  • 1.774
  • +2/-0
  • Geschlecht: Männlich
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #9 am: 12 November 2017, 11:59:40 »
habe mal einen Bugfix für den Editor zusammengepackt. Bitte mal testen.   :pardon:
den Inhalt des Paketes in das Verzeichnis "includes/wysiwyg/" kopieren, bzw den dort enthaltenen Ordner "ckeditor" überschreiben. Bitte auch sicherstellen, daß alle Dateien überschrieben werden.

Bitte um Feedback  :bye:

Download hier : https://www.pragmamx.org/modules.php?name=Downloads&op=view&lid=934
g

Olaf
...:::

Kein Support über PN, Mail !
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!


Offline waltkemper

  • ****
  • 328
  • +2/-10
Re: Nach update auf 2.4 wysiwig-Probleme
« Antwort #10 am: 14 November 2017, 16:03:35 »
Wenn die Version 4.72 ist dann wurde der Fehler behoben.

Viele Grüße aus Winterscheid