pragmaMx Support Forum pragmaMx Support Forum

Menüpunkte werden den Besuchern nicht angezeigt

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Tjatte

  • *
  • 3
  • +0/-0
Menüpunkte werden den Besuchern nicht angezeigt
« am: 07 März 2016, 13:25:18 »
Hallo,

ich verzweifel schon seit einiger Zeit an einem Problem. Nachdem ich die aktuellste Version von pragmamx auf meinem Webserver installiert hatte, lief alles soweit gut.  Ich gestaltete die Seite und fügte den Inhalt ein. Mir wurden Menüpunkte angezeigt. Kaum habe ich mich ausgeloggt, sehe ich nur die einzelnen Blöcke, aber ohne Menüpunkte.

Komischerweise tritt das nur bei den folgenden Blöcken auf: DATEI >> Modules_one, DATEI >> Modules_three, DATEI >> Menu. In den Blockeinstellungen wird mir angezeigt, dass diese Blöcke für jeden Besucher sichtbar sind. Die Blöcke werden auch jedem angezeigt, aber halt nicht der Inhalt der oben aufgezählten Blöcken..
Andere Blöcke, z.b. html Blöcke, können von Besuchern samt Inhalt begutachtet werden.


Ich hoffe, ihr könnt mir helfen.

Beste Grüße

P.S.: Systeminformationen
Pragmamx Version: pragmaMx 2.2.4.74 (2015-08-13)
PHP-Version: 5.6.18
MySql-Version: 5.5.47-log
Server-Version: Apache/2.2.31 (Unix)

Offline pyr0

  • ******
  • 705
  • +0/-15
  • Geschlecht: Männlich
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #1 am: 08 März 2016, 14:40:43 »
Hallo Tjatte

mach mal bitte in den Debugeinstellungen die Debugmeldung für alle auf Bildschirm kurzzeitig an und schau dir dann mal die Fehlermeldungen an.
Ohne weitere Angaben wie Website usw. kann ich jetzt auch nicht mehr machen. Aber du wirst bestimmt die Fehlermeldungen sehen und dann .... kannst Du das Problem bestimmt beheben.


Gruss pyr0
Kein Support über PN, Mail !
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!

Offline Tjatte

  • *
  • 3
  • +0/-0
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #2 am: 08 März 2016, 22:32:59 »
Huhu,

danke erstmal für die Antwort. Ich habe die Debugeinstellungen aktiviert und es sind 2 Fehlermeldungen angezeigt worden:

includes/classes/Language.php:
· Undefined index: user_lang on line 58
blocks/block-Newsticker.php:
· Function ereg() is deprecated on line 50

Inwiefern können diese Fehler Einfluss auf das Menü nehmen? Die aktuelle Version hoste ich aktuell auf http://w.jch-online.de (das 4.w ist schon richtig so)

Liebe Grüße

Offline TerraProject

  • ******
  • 1.943
  • +2/-0
  • Geschlecht: Männlich
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #3 am: 09 März 2016, 14:57:32 »
schau erstmal bitte nach, ob alle Module, oder link, welche sich in den Blöcken befinden sollen auch aktiviert und für alle in der gewählten Sprache sichtbar sind.

der zweite Fehler weist auf einen veralteten Block (Newsticker) hin, der nicht mehr mit der aktuellen PHP-Version kompatibel ist.
g

Olaf
...:::

Kein Support über PN, Mail !
Bitte die Fragen im Forum stellen, nur so helfen die Antworten auch den anderen Usern.
Bitte auch die Boardsuche nicht vergessen, oft ist genau dein Problem schon an anderer Stelle gelöst worden!


Offline Tjatte

  • *
  • 3
  • +0/-0
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #4 am: 29 April 2016, 21:31:31 »
Hallo,

konnte mich eine Zeit lang nicht mit dem Problem beschäftigen, aber nun muss ich mich wieder damit rumschlagen. Also das Problem besteht immernoch, allerdings konnte ich das ganze eingrenzen.

Ich habe ein Menü sowie einzelne Menüpunkte angelegt. Sofern ich die Pfade von den Menüpunkten leer lasse, kann sie jeder sehen, auch unangemeldete Nutzer..
Wenn ich aber jetzt z.B. ein Menüpunkt den Pfad zu einer Inhaltsseite gebe, verschwindet das Menüpunkt für unangemeldete Benutzer. Angemeldete Benutzer hingegen können den Menüpunkt weiter sehen...

Ich hoffe ihr könnt mir helfen.

P.S.: Die obigen Vorschläge bin ich schon durchgegangen, hat leider nicht geholfen :(

Offline anmShinichi

  • ****
  • 406
  • +4/-1
  • Geschlecht: Männlich
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #5 am: 04 Mai 2016, 08:56:46 »
Hallo,

ich finde die Website nicht. http://w.jch-online.de/ > Host not found


Gruß,
Ronny
MonsterWorks - www.monsterworks.de

Offline nudels64

  • ****
  • 282
  • +0/-0
  • Geschlecht: Männlich
  • Lieben Gruß Andreas
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #6 am: 04 Mai 2016, 13:28:31 »
Lieben Gruß
Andreas
#################################
CMS-Version:
pragmaMx 2.1.2.94 (2014-10-22)
PHP-Version:
5.6.24-he.0
MySQL-Version:
5.6.31-77.0-log
Server-Version:
Apache

Offline anmShinichi

  • ****
  • 406
  • +4/-1
  • Geschlecht: Männlich
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #7 am: 04 Mai 2016, 15:17:47 »
Aktuell scheint deine Notlösung ja zu greifen, weil ich alles eingeloggt aber auch ausgeloggt sehe.

brauche wieder ein Beispiel, das du aktivieren musst ;)
Registriert bin ich schonmal
MonsterWorks - www.monsterworks.de

Offline marcinstopa

  • *
  • 1
  • +0/-0
  • Geschlecht: Männlich
Re:Menüpunkte werden den Besuchern nicht angezeigt
« Antwort #8 am: 20 Mai 2016, 11:08:04 »
Im Menü (struktur> menü > Dein Menu) die Eltern-Items editieren und dort auf aufgeklappt stellen.

.