pragmaMx Support Forum pragmaMx Support Forum

pragmaMx V2.2.3 BETA

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Sarge31FR

  • ***
  • 152
  • +0/-10
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #20 am: 22 Mai 2015, 21:40:44 »
MySQL.

Ich hatte lokal mal mit der älteren 2.2.x PDO versucht, das ging aber nicht.
Werde mal am WE lokal testen, auf unserem Server ist mir das zu kritisch  :)

Offline Sarge31FR

  • ***
  • 152
  • +0/-10
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #21 am: 26 Mai 2015, 21:16:24 »
Habe doch noch ein Problem gefunden, und zwar im Bereich "Forum-action-pm.html", siehe Screenshot.
Hinweis: Den schwarzen Block habe ich eingefügt um die Nachrichten zu verdecken.
Sie werden mit Datum etc. angezeigt, aber offensichtlich gibt es ein Problem mit dem Design.



- Nachrichten lassen sich NICHT mehr durch anklicken öffnen.


- Wenn ich eine Nachricht (PM) verfassen will kommt eine weiße Seite mit der Zeile

You can't access this file directly...

- Wenn ich auf "Übersicht" klicke komme ich NICHT mehr normal zurück ins Forum, stattdessen öffnet sich die Seite "http://battlegroup42.de/modules/Forum/smf/index.php" ebenfalls mit der Meldung "You can't access this file directly..."
« Letzte Änderung: 26 Mai 2015, 21:26:52 von Sarge31FR »

Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #22 am: 19 Juli 2015, 18:22:10 »
hallo, wollte meine Internet Seite diesmal nicht updaten, sondern neu aufsetzen... habe 2.2.2 installieren wollen, klappte nicht, habe den Fehler hier im Forum gefunden und da wurde empfohlen gleich auf 2.2.3 zu wechseln, habe alles wieder gelöscht und Beta draufgepackt, nun kommt ein anderer Fehler:

1
Warning: mysqli_error() expects parameter 1 to be mysqli, boolean given in /home/www/..../setup/includes/mx_db_mysqli.php on line 351

Fatal error: Call to undefined function sql_errno() in /home/www/..../setup/includes/option_new.php on line 82

dass nicht mal Installation klappte, ist mir noch nie passiert.


Offline AlternativeComputing

  • ****
  • 874
  • +2/-2
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #23 am: 19 Juli 2015, 18:50:19 »
Stimmen die min. PHP und MySQL/mySQLi Versionen?
MfG

Peter

CMS-Version: pragmaMx 2.2.3.114 :: PHP-Version: 5.6.10 :: MariaDB (MySQL)-Version: 10.1.5 :: Server-Version: Apache 2.4.12-8.1 (Linux/SUSE)

Projekt: osc4pragmaMx- 2.3.2 : Abgeschlossen :: pmxCart 0.1: in der Entwicklung

Red Orchestra Ostront Extension RC 1: in der Entwicklung

Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #24 am: 19 Juli 2015, 18:59:07 »
die Installation hat ja erst wegen PHP Version gemeckert, habe von PHP 5 standart auf ON gestellt und erst dann ging es los mit der Installation, nachdem ich jetzt mitten in der Installation wegen dem Fehler aufhören musste, habe ich es wieder auf Standart gestellt, weil in der alten Pragma Version(also Hauptseiten Installation) einige Links im Menü unsichtbar geworden sind. Und siehe da, es ging mit der Installation weiter... merkwürdige Sache. Nach dem nun die Installation fertig ist, will die Beta, dass ich PHP 5 wieder auf ON stellen soll  :puzzled:

Offline AlternativeComputing

  • ****
  • 874
  • +2/-2
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #25 am: 19 Juli 2015, 19:04:23 »
Warum soll es nicht die 2.2.2 sein? Welchen Fehler meinst Du mit der 2.2.2?

Wenn Du den Fehler mit der SMF Bridge und dem UTF-8 Problem meinst, da bin ich bei.
MfG

Peter

CMS-Version: pragmaMx 2.2.3.114 :: PHP-Version: 5.6.10 :: MariaDB (MySQL)-Version: 10.1.5 :: Server-Version: Apache 2.4.12-8.1 (Linux/SUSE)

Projekt: osc4pragmaMx- 2.3.2 : Abgeschlossen :: pmxCart 0.1: in der Entwicklung

Red Orchestra Ostront Extension RC 1: in der Entwicklung

Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #26 am: 19 Juli 2015, 19:29:07 »
nein, ich meinte eine bloße 2.2.2 Installation ohne irgendwas dran
das war das, was ich gefunden hatte und auf Beta umgestiegen bin:
http://www.pragmamx.org/Forum-topic-34621.html


Offline AlternativeComputing

  • ****
  • 874
  • +2/-2
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #27 am: 19 Juli 2015, 19:37:22 »
Bei welchen Hoster bist Du?

Konnte die Probleme aus dem Link nicht reproduzieren und es wird auch die Seltenheit sein, das exakt dieser Fehler auftritt.

Ich habe jetzt schon 3 Seiten erfolgreich auf die 2.2.2 Upgedatet (Die Probleme mit meinen Modulen mal außen vorgelassen).

Zweimal von der 2.0 BETA und einmal von der 1.12.3.
MfG

Peter

CMS-Version: pragmaMx 2.2.3.114 :: PHP-Version: 5.6.10 :: MariaDB (MySQL)-Version: 10.1.5 :: Server-Version: Apache 2.4.12-8.1 (Linux/SUSE)

Projekt: osc4pragmaMx- 2.3.2 : Abgeschlossen :: pmxCart 0.1: in der Entwicklung

Red Orchestra Ostront Extension RC 1: in der Entwicklung

Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #28 am: 19 Juli 2015, 21:34:03 »
bin bei canhost und hatte sonst auch nie irgendwelche Probleme.

Offline AlternativeComputing

  • ****
  • 874
  • +2/-2
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #29 am: 19 Juli 2015, 23:11:22 »
Leg Dir mal ein zweiten Ordner (test) auf Deinen Webspace an und linke darauf eine Subdomain (test.meinedomain.tld).
Dann noch eine Datenbank anlegen.

Wenn das fertig ist, installierst du in den Ordner test das PMX 2.2.2.

Sollte das da sauber durchlaufen, kannst Du Deine Seite updaten. Bitte mache Vorher von den Webseiten PMX root und von der DB ein Backup.
MfG

Peter

CMS-Version: pragmaMx 2.2.3.114 :: PHP-Version: 5.6.10 :: MariaDB (MySQL)-Version: 10.1.5 :: Server-Version: Apache 2.4.12-8.1 (Linux/SUSE)

Projekt: osc4pragmaMx- 2.3.2 : Abgeschlossen :: pmxCart 0.1: in der Entwicklung

Red Orchestra Ostront Extension RC 1: in der Entwicklung

Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #30 am: 20 Juli 2015, 11:49:47 »
bei Neuinstallation von 2.2.2 kommt definitiv der Fehler:
SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client
Fatal error: Uncaught exception 'myDbException' with message 'SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client'....blablabla.../setup/includes/functions_db.php on line 99

wie gesagt, ich bekomme es nicht mal installiert. 2.1.2 letztes Jahr ging problemlos, ohne einen Mecker.

Offline AlternativeComputing

  • ****
  • 874
  • +2/-2
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #31 am: 20 Juli 2015, 14:15:55 »
Log Dich mal bei einer Funktionierenden Seite als Admin an und schaue welche MySql und PHP Version da läuft.
Das lässt sich leider bei Deinen Hoster  in den Angebotenen Paketen nicht erkennen.

Wenn da eine MySql und PHP Version niedriger als MySQL 5.0.33/ PHP 5.4 läuft, gibt es nur zwei alternativen:

 - A) Dein Hoster macht ein Update auf min. PHP 5.4 und MySql 5.0.33. Dafür musst Du den Anrufen oder eine Supportanfrage stellen.
 - B) Du musst Dir einen Hoster suchen der PHP 5.4 und MySql 5.0.33 oder höher im Programm hat.

1 und 1 wäre einer davon. Einige finden die Kacke, aber die haben immer recht aktuelle Versionen am Bord.

Infos zu dem Problem:

http://dba.stackexchange.com/questions/34024/server-requested-authentication-method-unknown-to-the-client-mysql-old-password

http://dba.stackexchange.com/questions/33447/connect-error-2054-mysql-old-password-issue-still-not-solved/33508#33508

http://stackoverflow.com/questions/1340488/mysql-php-incompatibility
« Letzte Änderung: 20 Juli 2015, 14:32:18 von AlternativeComputing »
MfG

Peter

CMS-Version: pragmaMx 2.2.3.114 :: PHP-Version: 5.6.10 :: MariaDB (MySQL)-Version: 10.1.5 :: Server-Version: Apache 2.4.12-8.1 (Linux/SUSE)

Projekt: osc4pragmaMx- 2.3.2 : Abgeschlossen :: pmxCart 0.1: in der Entwicklung

Red Orchestra Ostront Extension RC 1: in der Entwicklung

Offline waltkemper

  • ****
  • 335
  • +2/-10
Re:pragmaMx V2.2.3 BETA
« Antwort #32 am: 20 Juli 2015, 15:29:44 »
Hallo zusammen, bei vielen Hostern kannst du die Version einfach per htaccess schalten. Frag mal danach. Ich unterhalte neben 1&1 noch Greatnet Pakate da geht das auch über die htaccess.

Grüße aus Winterscheid

Offline AlternativeComputing

  • ****
  • 874
  • +2/-2
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #33 am: 20 Juli 2015, 15:37:29 »
Hallo zusammen, bei vielen Hostern kannst du die Version einfach per htaccess schalten. Frag mal danach. Ich unterhalte neben 1&1 noch Greatnet Pakate da geht das auch über die htaccess.

Grüße aus Winterscheid

Bei diesen Speziellen Problem ist es leider nur mit der PHP Umstellung nicht getan.

Sondern explizit das Zusammenspiel von MySql und PHP.
Sind diese beide nicht zueinander kompatibel gibt es dieses Problem.

Aber das der neue Hoster das Umschalten per .htacces erlaubt setze ich mal zum wechseln voraus.
MfG

Peter

CMS-Version: pragmaMx 2.2.3.114 :: PHP-Version: 5.6.10 :: MariaDB (MySQL)-Version: 10.1.5 :: Server-Version: Apache 2.4.12-8.1 (Linux/SUSE)

Projekt: osc4pragmaMx- 2.3.2 : Abgeschlossen :: pmxCart 0.1: in der Entwicklung

Red Orchestra Ostront Extension RC 1: in der Entwicklung

Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #34 am: 22 Juli 2015, 12:51:06 »
meine Serverdaten laut Info der Adminseite einer laufender PragmaMX

PHP-Version:
    5.3.29  (PHP-Info)

MySQL-Version:
    5.5.43-0+deb7u1

Server-Version:
    Apache/2.2.22 (Debian)

und trotzdem kann ich keine neue Pragma installieren.
PHP kann ich beliebig auf 5.4 oder 5.5 schalten(zur Installation hatte ich es auch), nur dann funktioniert meine alte Version Pragma teilweise  nicht mehr.
« Letzte Änderung: 22 Juli 2015, 12:55:52 von Lijana »

Offline AlternativeComputing

  • ****
  • 874
  • +2/-2
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #35 am: 22 Juli 2015, 13:32:12 »
Gut Du kannst die PHP Versionen wechseln, dennoch wirst Du PHP 5.4 für das PMX 2.2.2 und höher brauchen.
Das sind die Mindestanforderungen.



MfG

Peter

CMS-Version: pragmaMx 2.2.3.114 :: PHP-Version: 5.6.10 :: MariaDB (MySQL)-Version: 10.1.5 :: Server-Version: Apache 2.4.12-8.1 (Linux/SUSE)

Projekt: osc4pragmaMx- 2.3.2 : Abgeschlossen :: pmxCart 0.1: in der Entwicklung

Red Orchestra Ostront Extension RC 1: in der Entwicklung

Offline SIM278

  • **
  • 65
  • +0/-3
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #36 am: 23 Juli 2015, 07:57:40 »
Guten Morgen,

vielleicht blöde Frage, aber wie kann ich die PHP Version auf 5.4 oder höher wechseln?  :red:

Danke und Gruß
Günter


Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #37 am: 23 Juli 2015, 10:17:34 »
Gut Du kannst die PHP Versionen wechseln, dennoch wirst Du PHP 5.4 für das PMX 2.2.2 und höher brauchen.
Das sind die Mindestanforderungen.




das ist ja nicht das Problem, ich kann es ja beliebig einschalten bei Bedarf, nur auch eingeschaltet bekomme ich nicht installiert, das ist das Problem...und liegt nicht mal an PHP sondern an der Datenbank, siehe Fehler.

Offline Lijana

  • ***
  • 130
  • +0/-2
  • Geschlecht: Weiblich
Re:pragmaMx V2.2.3 BETA
« Antwort #38 am: 23 Juli 2015, 10:20:43 »
Guten Morgen,

vielleicht blöde Frage, aber wie kann ich die PHP Version auf 5.4 oder höher wechseln?  :red:

Danke und Gruß
Günter


das musst du bei deinem Anbieter erfragen ob das bei ihm geht, bei canhost ist es in den Programierung/http Special Einstellungen a la "Hier können Sie per Httpd.Spezial für alle im Tarif vorhandenen Domains nach Tarifauswahl Einfluss auf die Globale PHP.INI nehmen" hinterlegt.
« Letzte Änderung: 23 Juli 2015, 10:26:53 von Lijana »

Offline SIM278

  • **
  • 65
  • +0/-3
  • Geschlecht: Männlich
Re:pragmaMx V2.2.3 BETA
« Antwort #39 am: 23 Juli 2015, 11:59:12 »
OK, Danke,  :smile: