pragmaMx Support Forum pragmaMx Support Forum

[gelöst] Verwirrung um mein mx-e-board und eine Fehlermeldung mit Folgen

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline trulla

  • *****
  • 527
  • +1/-14
  • Geschlecht: Weiblich
 :puzzled:
Der Titel dieses Forums heisst mx-board (nicht eboard). An anderer Stelle lese ich, dass das e-board nicht mehr supportet wird. Weil auf meiner Webseite aber das e-board installiert ist,habe ich mich nicht getraut, mein Problem zu schildern. Stattdessen habe ich mir das mx-board runtergeladen, entpackt und angeschaut und habe festgestellt, dass es nach dem Entpacken e-board heisst. Ich habe also das mx-board, dass auf meiner Webseite e-board genannt wird. Ich hoffe Ihr seid nun nicht ebenfalls verwirrt.

Nun zu meinem eigentlichen Problem

Zugegeben ist auf meinem Forum nicht viel los. Immerhin zwei Beiträge. Im Userprofil jeden Users wird ein Reiter mit Namen Forumsprofil angezeigt. Gehe ich nun auf das Forums-Profil eines Users, der noch nie einen BLick ins Forum geworfen hat, kommt der Hinweis ungültiger Username.

So weit, so tragisch. In meiner goggel-Webmaster-Zentrale sind derartige Links so beschrieben:
Zitat
Die Ziel-URL existiert nicht und Ihr Server gibt keinen 404-Fehler "Datei nicht gefunden" zurück.

Frage:
  • wie schlimm ist das?
  • kann man es so einstellen, dass der Link (Reiter) zum Forumsprofil bei inaktiven Forumsusern verschwindet?
  • Habe ich etwas falsch eingestellt, wodurch dieser Fehler verursacht wird?

Würde mich freuen, wenn jemand weiss, was falsch läuft.
Danke

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re:Verwirrung um mein mx-e-board und eine Fehlermeldung mit Folgen
« Antwort #1 am: 30 März 2012, 14:41:21 »
Hi :)

der Standardinstallationsordner des mxBoard lautet aus Kompatibilitätsgründen (leider) immer noch eBoard. Das hat aber mit dem eigentlichen Modul nichts zu tun, es ist trotzdem ein mxBoard und kein uraltes eBoard. Der Installationsordner des Moduls kann ja beliebig gewählt werden. Wir haben hier auch ein mxBoard laufen und der Ordnername lautet "testboard" anstatt eboard oder mxboard...
Also keine Gedanken, einfach guggen was drunter steht ;)
Zitat
mxBoard 1.2.1, © 2011 by pragmaMx.org

Stimmt, die Meldung beim Userprofil ist unschön. Ich habe das im Bugtracker eingetragen, damit wir das zur nächsten Version ändern.

Negative Auswirkungen auf Google oder andere Suchmaschinen hat das aber nicht. M.E. haben Suchmaschinen in Userprofilen eh nichts verloren und der 404er Fehler wird hier auch nicht generiert, zumindest nicht vom mxBoard oder von pragmaMx. Beim klick auf den nicht vorhandenen User wird ein genz normaler 200er Status erzeugt, siehe screenshots.
schön´s Grüssle, Andi

Offline trulla

  • *****
  • 527
  • +1/-14
  • Geschlecht: Weiblich
Re:Verwirrung um mein mx-e-board und eine Fehlermeldung mit Folgen
« Antwort #2 am: 30 März 2012, 15:03:17 »
 :) Ok, danke für die Antwort. Dann kann ich heute beruhigt schlafen.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Moin :)

anbei die geänderte /modules/eBoard/core/user.visitmenu.php

Der Forumsprofil-Tab wird damit nur noch angezeigt, wenn für den User auch wirklich ein Forumsaccount existiert...

schön´s Grüssle, Andi