pragmaMx Support Forum pragmaMx Support Forum

[Solved] problem mit uploadfeldern in cpg ( seit update)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
da der folgende "Fehler" erst seid dem update auf 0.11 auftritt schreib ich es mal hier .
also die Hintergrundfarbe bei den Uploadfeldern ist weiss .. oder fast weiss. Die Schriftfarbe auch ..  Wo kann ich das ändern ?
Demobild:
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline Biker

  • *******
  • 1.609
  • +4/-29
  • Geschlecht: Männlich
    • Privat- u. Wirtschaftsdetektei Martin
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #1 am: 16 Mai 2009, 21:38:46 »
Ich denke mal, Du meinst nicht das Update des PragmaMx, sondern das Update 1.4.22.1 der Coppermine, weil Du ja cpg geschrieben hast!?
Dann müsste jemand vom Team den Beitrag hier bitte mal ins richtige Forum schieben!


Guck doch mal bitte welches Design Du aktuell für die Coppermine eingestellt hast.
Bei mir war das auch nach dem Update, weil durchs Update das Design auf das Standard-Design umgestellt wird.

Geh mal in der Coppermine auf Einstellungen und dann guck mal, ob dort unter "Design-Einstellungen" das Design auf "Mx-port" steht.
Änder es auf "Mx-port-black" und speicher es unten ab, dann müssten die Felder wieder dunkel sein!

Da Du ja auch ein dunkles Design verwendest....ich hab mal die Buttons für das Mx-port-black" angepasst, weil die vorhandenen nicht für dunkles / schwarzes Design geeignet sind.

Wenn Du sie haben willst....ich häng sie mal an!
Die kommen in den Ordner: /modules/Coppermine/themes/mx-port-black/images/admin/

Gruß
Bernd

Detektei Martin - wir bringen Licht ins Dunkle!

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #2 am: 16 Mai 2009, 22:00:56 »
ich meine pragmaupdate 
da es gestern noch keine beschwerden von den usern gab  - und mir das selbst noch nicht aufgefallen war ( gestern : schwarze schrift )
und -..  das ist mx-port-dark ;)

hab grade mit firebug geschaut . das spukt er aus :
Zitat
http://www.fraktal-schmiede.de/layout/style/default.css.php?t=mx-darkbreak&skipcache
form input, form input[type="text"], form input[type="file"], form input[type="password"], form textarea, form select {default....skipcache (Linie 79)
background-color:#252525;
border-color:#323232 #1E1E1E #1E1E1E #323232;
border-style:solid;
border-width:1px;
color:#FFFFFF;
}
wo finde ich das ?

unter mx-port ist es noch schlimmer  - weisse schrift auf weissen buttons
« Letzte Änderung: 16 Mai 2009, 22:26:31 von grafikmurkser »
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #3 am: 16 Mai 2009, 22:44:17 »
leider kein edit mehr möglich  ..

ich brauich garnicht weiter suchen denn
Zitat
background-color:#252525;
das ist nicht weiss.. das ist nichtmal eine helle farbe  . das ist die farbe  - die es sein sollte  - dunkel  - sehr dunkel
wie das "dunkel" aussieht sieht man oben -in den textfeldern 

eine nachfrage ergab : erst seid dem update heute
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline Baldyman

  • *****
  • 1.084
  • +0/-2
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #4 am: 16 Mai 2009, 22:53:48 »
Häng mich mal hier dran.
Hab auch das mx-darkbreak, und das selbe Phänomen.
Finde aber auch nicht die verantwortliche Stelle.
Mit dem Firebug find ich die Stelle einfach nicht, da der irgendwas mit blablablaskipcache ausspuckt  :puzzled:
Wo auch immer das sein soll.

Hab das Phänomen aber auch im SMF, wenn man Dateianhänge hinzufügen will.
Weiße Schrift auf weißem Grund.

@Andi
Hatte das vom SMF mal im Bugtracker gemeldet.
Ist evtl. das selbe wie in der CPG ?

Offline SvenW

  • *******
  • 1.283
  • +5/-1
  • Gruss Sven
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #5 am: 16 Mai 2009, 22:59:03 »
Mit dem Firebug find ich die Stelle einfach nicht, da der irgendwas mit blablablaskipcache ausspuckt  :puzzled:
Wo auch immer das sein soll.


/modules/Gallery/themes/mx-port-black/style.css

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #6 am: 16 Mai 2009, 23:08:16 »
danke ich schau noch mal  ...
ich find nur farbwerte die NICHT mit dem übereinstimmen was zusehen ist ( background = #252525 = sehr dunkel )

habs gefunden .. sieht bei mir alles bissel anders aus  wie bei dir :
Zitat
listbox {modules....ack&noJpC (Linie 10)
border:1px solid #1E1E1E;
vertical-align:middle;

richtig intressant wirds wenn ich beim Käfer  , ganz rechte unter Einstellungen Berechnete Styles anzeigen aktiviere
Zitat
Text
font-family   verdana,sans-serif
font-size   12px
font-weight   400
font-style   normal
color   #FFFFFF
text-transform   none
text-decoration   none
letter-spacing   normal
word-spacing   normal
line-height   14px
text-align   left
vertical-align   middle
direction   ltr
Hintergrund
background-color   #252525
background-image   none
background-repeat   repeat
background-position   0 0
background-attachment   scroll
opacity   1
Box-Modell
width   328px
height   23px
top   auto
right   auto
bottom   auto
left   auto
margin-top   1px
margin-right   1px
margin-bottom   1px
margin-left   1px
padding-top   0
padding-right   0
padding-bottom   0
padding-left   0
border-top-width   0
border-right-width   0
border-bottom-width   0
border-left-width   0
border-top-color   #323232
border-right-color   #1E1E1E
border-bottom-color   #1E1E1E
border-left-color   #323232
border-top-style   none
border-right-style   none
border-bottom-style   none
border-left-style   none
Layout
position   static
display   inline
visibility   visible
z-index   auto
overflow-x   visible
overflow-y   visible
white-space   nowrap
clip   auto
float   none
clear   none
-moz-box-sizing   content-box
Anderes
cursor   default
list-style-image   none
list-style-position   outside
list-style-type   disc
marker-offset   auto
man beachte was als backgroundcolor steht #252525 . Kein Hintergrundbild ..  ich werd aber das Gefühl nicht los das dort ein Bild eingebunden ist . Mit Web Developer->Infos -> Color Infos lässt sich die "elfenbeinartige Farbe"  nicht ermitteln


12 Rückmeldung : seit heute
« Letzte Änderung: 16 Mai 2009, 23:20:52 von grafikmurkser »
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline SvenW

  • *******
  • 1.283
  • +5/-1
  • Gruss Sven
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #7 am: 16 Mai 2009, 23:13:48 »
Vermutlich muss man beim suchen den Design-Cache in den Einstellungen im pragmaMx deaktivieren, da das CSS gecached wird…

Versuch macht klug!  :BD:

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #8 am: 16 Mai 2009, 23:25:21 »
aha .. bei mir ist Designcache aber schon seit Monaten deaktiviert ..

und damit man glaubt was oben steht :
« Letzte Änderung: 16 Mai 2009, 23:36:01 von grafikmurkser »
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #9 am: 17 Mai 2009, 10:06:21 »
also  um endlich hier mal weiter zu kommen ....  und der ...  diskusion ob der "fehler" durch das pragma-update verursacht wird oder nicht, ein ende zu bereiten :
ich hab den layout-ordner umbenannt, so er nicht mehr gefunden wird- und siehe da : alles so wie es sein soll
schwarze schrift auf weissem hintergrund .....
wobei man ja schon an der backgroundfarbe der felder sieht das hier eine änderung erfolgt

ergo: was muss wo an den layout-dateien geändert werden ... ?
« Letzte Änderung: 17 Mai 2009, 10:25:04 von grafikmurkser »
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #10 am: 17 Mai 2009, 10:57:34 »
Nunja.. Andi hat mir gerade nochmal den Hiweis geschickt das es zu Änderungen im Style ( Ansichtsänderungen) kommen kann ....
Was logisch ist , man kann nicht dutzende Themes durchtesten. Schon garnicht wenn sie so verschieden gecodet sind. Mal HTML , mal XHTML, mal "web2" ..

Ich hab bei mir die Lösung gefunden : in der default.forms.css im layout-Verzeichniss...

form input,
form input[type=text],
form input[type=file],
form input[type=password],
form textarea,
form select {
   background-color: ___alternate-0___;
   border-color: ___bordercolor-dark___ ___bordercolor___ ___bordercolor___ ___bordercolor-dark___;
   border-style: solid;
   border-width: 1px;
   color: ___textcolor2___;
}

form input,
form textarea,
form select {
   font-size: 1em;
   padding-bottom: .18em;
   padding-left: .2em;
   padding-right: .1em;
   padding-top: .15em;
   text-align: left;
}



geändert in :
form input,
form input[type=text],
form input[type=file],
form input[type=password],
form textarea,
form select {
   background-color: #ffffff;
   border-color: ___bordercolor-dark___ ___bordercolor___ ___bordercolor___ ___bordercolor-dark___;
   border-style: solid;
   border-width: 1px;
   color: #000000;
}

form input,
form textarea,
form select {
   font-size: 1.1em;
   padding-bottom: .18em;
   padding-left: .2em;
   padding-right: .1em;
   padding-top: .15em;
   text-align: left;
}
damit sind beide Fragen ( zu cpg und smf ) erledigt

Danke an alle die versucht haben eine Lösung zu finden. Danke Andi für die Geduld
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #11 am: 17 Mai 2009, 11:31:17 »
Moin :)

grafikmurkser, du bist zu schnell, ich bin noch am testen und wollte folgendes schreiben:


ich habe mir das jetzt mal angesehen...

Nur zur Sicherheit, das Problem tritt nur im Firefox auf, oder?
Opera und ie8 müsste es passen...

Das scheint das alte Problem des Firefox zu sein (weiss nicht, ob gewollt, oder Bug), dass der die Dateiuploadfelder anders behandelt, als andere Eingabefelder.
Nur dachte ich die ganze Zeit, dass der die Uploadfelder garnicht formatieren lässt. Aber anscheinend formatiert er doch die Schriftfarbe, ignoriert aber die Hintergrundfarbe....

Entsprechend kommt es jetzt zu dem Konflikt, der beiden Farben in den dunklen themes.

Zuständig dafür ist die /layout/style/default.forms.css, die automatisch in das dynamische Stylesheet eingelesen wird. Dieser Bereich:
form input,
form input[type=text],
form input[type=file],
form input[type=password],
form textarea,
form select {
   background-color: ___alternate-0___;
   border-color: ___bordercolor-dark___ ___bordercolor___ ___bordercolor___ ___bordercolor-dark___;
   border-style: solid;
   border-width: 1px;
   color: ___textcolor2___;
}

Hier sollte dann noch eine Lösung kommen....


Deine Lösung ist zwar nicht optimal, ich such auch noch ne bessere Lösung, aber es wird hier zumindest weiter helfen....
schön´s Grüssle, Andi

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: [Solved] problem mit uploadfeldern in cpg ( seit update)
« Antwort #12 am: 17 Mai 2009, 12:09:47 »
Hallo Andi,
ich hab nochmal die Orginal-default.forms.css hochgeladen . Um im IE zu schauen. Und Du hast Recht. Das tritt nur im FF auf. Im IE ist der Hintergrund dunkel. Dann schnell noch geschaut wer von meinen Usern da "gemeckert" hat -  und ja - es sind User von denen ich weiss das sie den FF benutzen ....
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: [Solved] problem mit uploadfeldern in cpg ( seit update)
« Antwort #13 am: 17 Mai 2009, 12:36:58 »
Hoi :)

ich bin noch dran...

Aber zwischendrin:
An den default Stylesheets sollte eigentlich nichts geändert werden. Die sind durch "plugins" anpassbar, so dass beim nächsten Update nicht alles wieder weg ist.

Lege im Ordner /layout/style/ eine neue css Datei an, deren Name mit custom beginnt, also z.B. custom.uploadfelder.css
Die Datei könnte dann entsprechend deinen Änderungen, folgenden Inhalt haben:
form input[type=text],
form input[type=file],
form input[type=password],
form textarea,
form select {
   background-color: #ffffff;
   color: #000000;
   font-size: 1.1em;
}
Diese Anweisungen überschreiben die Anweisungen vom normalen Stylesheet und es sollte dann genauso aussehen, wie mit deinen Änderungen....


Besser wäre das natürlich in das Theme-Stylesheet zu integrieren, weil es ja nur das dunkle Theme betrifft....
schön´s Grüssle, Andi

Offline Baldyman

  • *****
  • 1.084
  • +0/-2
  • Geschlecht: Männlich
Re: [Solved] problem mit uploadfeldern in cpg ( seit update)
« Antwort #14 am: 17 Mai 2009, 13:12:12 »
ahhh ... dann warte ich auch mal.

Hatte es für mich heute Nacht so gelöst.
Hab einfach in der /layout/style/default.forms.css das form input[type=file] rausgezogen,
und extra gelistet  :BD:

form input,
form input[type=text],
form input[type=password],
form textarea,
form select {
   background-color: ___alternate-0___;
   border-color: ___bordercolor-dark___ ___bordercolor___ ___bordercolor___ ___bordercolor-dark___;
   border-style: solid;
   border-width: 1px;
   color: ___textcolor2___;
}


form input[type=file]{
   background-color: ___alternate-0___;
   border-color: ___bordercolor-dark___ ___bordercolor___ ___bordercolor___ ___bordercolor-dark___;
   border-style: solid;
   border-width: 1px;
   color: #000000;
}


Aber das mit dem custom.blablabla.css im /layout/style/ Ordner ist gut zu wissen ;)

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #15 am: 17 Mai 2009, 14:58:48 »
ich hab jetztmal das "Theme gelöst" aufgehoben, da es ja noch nicht  100% gelöst ist ..*g

@ Baldyman  danke für den Tip, werd ich dann mal bei mir testen ;)

bzw. ich werde Deine Lösung - und Andis neue Lösung mal kombinieren ;)


Edit: also ich hab jetzt alle Lösungen, die von Andi mit der Extradatei, Baldymans Codes + die Änderung der Schriftgrösse im smf
kombiniert ..  und - es funktioniert .. 

hier der Inhalt der custom..css

/**
 * This file is part of
 * pragmaMx - Web Content Management System.
 * Copyright by pragmaMx Developer Team - http://www.pragmamx.org
 * $Id: custom.uploadfelder.css,v 1 2009/05/17 15:20:00 Baldyman, Andi ( pragmamx-Teamleader), grafikmurkser
 * mit dieser Datei wird ein Formatierungsproblem des Internetbrowsers
 * Firefox  provisorisch behoben. Weitere Infos dazu findet man hier:
 * http://www.pragmamx.org/Forum-topic-29394.html
 */


form input,
form input[type=text],
form input[type=password],
form textarea,
form select {
   background-color: ___alternate-0___;
   border-color: ___bordercolor-dark___ ___bordercolor___ ___bordercolor___ ___bordercolor-dark___;
   border-style: solid;
   border-width: 1px;
   color: ___textcolor2___;
}

form input[type=file]{
   background-color: ___alternate-0___;
   border-color: ___bordercolor-dark___ ___bordercolor___ ___bordercolor___ ___bordercolor-dark___;
   border-style: solid;
   border-width: 1px;
   color: #000000;
}

form input,
form textarea,
form select {
   font-size: 1.1em;
   padding-bottom: .18em;
   padding-left: .2em;
   padding-right: .1em;
   padding-top: .15em;
   text-align: left;
}
« Letzte Änderung: 17 Mai 2009, 15:30:33 von grafikmurkser »
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #16 am: 17 Mai 2009, 23:23:20 »
Achtung!

Bevor jetzt alle Welt her geht und bastelt wild irgendwelche Custom Datein:

Bitte dran denken, dass sich diese Änderungen systemweit bei allen Themes auswirken.
Also gerade Farbangaben können da zu verrückten Ergebnissen führen wenn man versch. Themes verwendet, oder das Theme irgendwann mal wechselt.
Die Custom Datein sind dafür gedacht, z.B. Anzeigefehler wie zentrierte Ausrichtung, in bestimmten Bereichen z.B. bei eigenen Modulen oder sonst wo zu beheben.

Bei allgemeinen Anzeigefehlern, insbesondere bei den Farben, sollte die Änderung im Theme vorgenommen werden.
Hier ist gerade in den älteren Themes, wie rainbow, oder auch carbon, soviel Mist drin, das muss dort geändert werden!!!
schön´s Grüssle, Andi

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #17 am: 17 Mai 2009, 23:51:32 »
So, nochwas zur Lösung...

Ich wollte ja erst was globales machen, aber das macht keinen grossen Sinn, weil
- es in der Regel nur dunkle Themes betrifft und da
- auch nur die wenigen Module, die überhaupt upload-Felder anbieten und
- nur im Firefox auftritt

Mein Vorschlag wäre, an alle die mit dem Problem zu kämpfen haben und alle die künftig ein Theme basteln/ändern, folgende Zeilen mit in die Funktion theme_header() des jeweiligen Themes mit aufzunehmen:

    if (strpos($_SERVER['HTTP_USER_AGENT'], 'Gecko') !== false){
        pmxHeader::add_style_code('form input[type=file]{background-color:Window; color:WindowText;}');
    }
Das überschreibt die Formatierung der default.css und zeigt im Gecko die Eingabefelder in den beim Betriebssystem eingestellten Farben an, was dem Normalzustand im Firefox entspricht. So bleibt die "schönere" Formatierung in allen anderen Browsern erhalten.

Die für mich einzig andere Alternative wäre, die Formatierung der Uploadfelder ganz aus dem default Stylesheet rauszunehmen....



im mx-darkbreak würde die Funktion in der theme.php dann so aussehen:
function theme_header($newheader)
{
    global $theme_template;
    // den body-Tag hinter head-Ende setzen
    $newheader .= "\n</head>\n\n" . $theme_template['body_tag'] . "\n\n";
    // ersetzen von eigenen Theme-Elementen, kann veraendert und ergaenzt werden
    // diese Teile werden vor der Ausgabe des headers im Headbereich ersetzt
    if (function_exists('theme_replace_header')) {
        $newheader = theme_replace_header($newheader);
    }
    /* Im Gecko (Firefox) die Uploadfelder farblich zurücksetzen */
    if (strpos($_SERVER['HTTP_USER_AGENT'], 'Gecko') !== false){
        pmxHeader::add_style_code('form input[type=file]{background-color:Window; color:WindowText;}');
    }
    return $newheader;
}
schön´s Grüssle, Andi

Offline grafikmurkser

  • *******
  • 1.860
  • +13/-59
  • Geschlecht: Männlich
Re: problem mit uploadfeldern in cpg ( seit update)
« Antwort #18 am: 18 Mai 2009, 00:10:02 »
merci Andi  :thumbup: :thumbup:
ich mach hier wieder "zu" damit dürfte das Problem erledigt sein ..
meine pmx-Seite : die erste und einzige, freie, deutschsprachige Community rund um fraktale Bilder apophysis-schmiede   reg.User mehr als 1000