pragmaMx Support Forum pragmaMx Support Forum

[Solved] Warum müssen seit der Version 0.1.11 so viele Elemente nachgeladen werden?

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline powerline

  • ***
  • 121
  • +1/-5
  • Geschlecht: Männlich
Hallo Leute,

erstmal Danke für die neue Version und Euren Supporteinsatz.
Ich hab nun auch ein Problem, das ich zwar schon hier im Forum und den Pmx-Seiten festgestellt habe, hab aber damals nur gedacht das das ein Serverproblem von Euch ist.

Zu allererst hier mal eine Grafik damit ihr seht was ich meine:



Ich hab eine nagelneue 0.1.11 Installation,
als ich die das erste mal aufrief und so schaute was alles neu ist mussten ständig noch zwischen 80 und 250 Elemente nachgeladen werden. Klick ich mich dann so durch die einzelnen Funktionen müssen ständig ca. 80 Elemente nachgeladen werden, obwohl die Seite schon angezeigt wird. Stellt sich mir die Frage was läd da alles nach wenn doch schon alles zu sehen ist und warum?
Wenn ich ein neues Theme in den Einstellungen aktiviere und die Seite sich läd fängt der Zähler unten links im Browser bei 400 an rückwärts zu laufen. Das ganze dauert dann ca. 45-60 sec. trotz 6000er DSL.
Mir ist das sonst wo und bei den Versionen bis 0.1.10 nie aufgefallen.

Es ist ja nicht nur das da unten links im Browser die Anzeige Rückwärts zählt, in dieser Zeit blinkt auch ständig die Sanduhr neben dem Mauszeiger und der CPU fährt auf 80-90% Last.

Könnt Ihr Euch das erklären?

Für schnelle Hilfe und Ideen wäre ich dankbar weil ich eigentlich mit der neuen Version ein neues Projekt anfangen wollte.
Wenn sich das aber nicht abstellen lässt würde ich auf die 0.1.10 er ausweichen.

Gruß und Danke

Offline Franky

  • *******
  • 1.610
  • +9/-23
  • Geschlecht: Männlich
ähnliches fällt mir im Adminmenü auf.

Das neue Admin-Layout braucht extrem lange zum laden.

Sieht so aus, als würde das Adminmenü auch bei jedem Aufruf der Seite komplett neu geladen. Das dauert.

Das ging vorher wesentlich schneller.

Vielleicht könnt ihr hier noch Abhilfe schaffen.

Oder ist das nur bei mir so?¿

bye
Frank :-)
"Ich möchte schlafend sterben, wie mein Opa, nicht schreiend, wie sein Beifahrer."

Offline xmjay

  • *******
  • 1.611
  • +9/-3
  • Geschlecht: Männlich
Huhu !

Kann ich nicht bestätigen, habe momentan drei Updates + eine Neuinstallation (liegen alle bei Hosteurope) durchgeführt, bei mir sind die Ladezeiten  ultraschnell, mit FF + IE getestet (DSL 3000).

Oder ist das nur bei mir so?¿
CMS-Version: pragmaMx 1.12.3 | PHP-Version: 5.2.12 | MySQL-Version: 5.1.66

Offline SvenW

  • *******
  • 1.283
  • +5/-1
  • Gruss Sven
Oder ist das nur bei mir so?¿


Bei meinem Yaml Theme rennt das mit meinem smarten DSL auch einwandfrei.

Evtl. liegt es auch an den Themes?







Offline powerline

  • ***
  • 121
  • +1/-5
  • Geschlecht: Männlich
also alles was mit Backend zu tun hat ist extrem langsam auf meiner neuinstallation.
Selbst hier im Forum zwischen den einzelnen Beiträgen und Rubriken hin und her dauert alles sehr lange.
Ständig geht die Anzeige die mir anzeigt noch xx Elemente unten im Browser auf ca.200 hoch.
Ständig blinkt die Sanduhr am Mauszeiger.
CPU Last liegt beim Laden der Administration immer zwischen 30 und 80%.
Das ganze dauert dann über eine Minute bis alles wieder normal ist.
Dann klick ich eine andere Funktion an dann geht das ganze wieder von vorne los. CPU Last geht nach oben usw.

Ich hab jetzt mal das mx-default und das mx-black getestet.
XHTML Themes noch nicht.

netzer

Das mit den langen Ladezeiten kann ich nicht bestätigen.
Bei mir geht alles recht flott.

Habe ein älteres Theme: mx-blue-sand

Offline powerline

  • ***
  • 121
  • +1/-5
  • Geschlecht: Männlich
das mit den Ladezeiten verhält sich folgendermaßen:
jeder klick egal wo ich hin möchte auf der Seite funktioniert so wie ich es bei Pragma und mit DSL gewohnt bin.
Nur leider werden zich Elemente noch "unsichtbar" nachgeladen obwohl die Seite schon längst funktionsfähig vor mir liegt.
Man sieht das halt im IE weil es angezeigt wird, im FF merk ich es halt wenn ich die CPU Last beobachte.

Offline SvenW

  • *******
  • 1.283
  • +5/-1
  • Gruss Sven
Man sieht das halt im IE weil es angezeigt wird, im FF merk ich es halt wenn ich die CPU Last beobachte.


IE6?


Offline powerline

  • ***
  • 121
  • +1/-5
  • Geschlecht: Männlich
ja IE6!  schlimm?

muss jetzt zur Arbeit werde morgen früh weiter lesen.

Danke

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Moin :)

also hier auf der Seite läuft die 0.1.11 schon seit Beginn an. In den letzten Monaten wurden hier ständig die neusten Betapakete hochgeladen und dadurch "hardcore" mitgetestet. Seit ca. 2 Monaten hat sich nichts grundlegendes mehr geändert, was solche Probleme verursachen könnte. Bis heute hat sich kein User diesbezüglich negativ geäussert.
Auch bei den Betatestern wurden bis jetzt keine Auffälligkeiten bemerkt.
Ein CMS mit Ladezeiten von 45sec hätten wir auch sicher nicht veröffentlicht.

Zitat
was alles neu ist mussten ständig noch zwischen 80 und 250 Elemente nachgeladen werden
Ich habe gerade unsere Startseite, die Forenstartseite und die Demoseite durch einen Web Page Analyzer geschickt und es wurden zwischen 20 und 35 Objekte geladen. Mehr sind es nicht....


edit:

IE6 ?
Nee, oder?
Dann hast du sicher den Hinweis beim Aufruf unserer Seite gelesen ;)
schön´s Grüssle, Andi

Offline Baldyman

  • *****
  • 1.084
  • +0/-2
  • Geschlecht: Männlich
Moinsen zusammen  :bye:

Hatte bis vor kurzem hier auch noch eine alte Möre hier rumstehen mit Win2000 und IE6.
Da war das gleiche Problem.
Nachdem ich das Teil in den Müll geworfen habe :crash: , neues Betriebssystem und Browser war es weg  :BD:

Offline comedi

  • ****
  • 733
  • +7/-1
  • Geschlecht: Männlich
Hallo zusammen, :BD:

habe jetzt mal schnell erst 4 Update gemacht, auf verschiedenen Systemen und mal kurz alles probiert. Habe nirgends ein solches Nachladen feststellen können.

Also bei mir alles gut. Mal wieder ein gutes Update. Danke an das PMX Team :drinks:
LG Michael


Kein Support über PN, Mail oder ICQ!

CMS-Version: pragmaMx 1.12.3 --- PHP-Version: 5.3.5
MySQL-Version: 5.1.63 --- Server-Version: Apache 2.2.4

Wer den Weg zum Ziel kennt - dann aber Umwege nimmt - muss sich nicht wundern wenn er sein Ziel nicht findet!


Gemeinschaftseite: www.pragmamx-erweiterungen.de

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Hoi :)

hat mir irgendwie keine ruhe gelassen, weil ich das in meiner virtuellen Umgebung und dem ie6 auch nachvollziehen konnte....

Also, es ist ein ie6 spezifisches Problem.
Für diesen alten Schrottbrowser haben wir im default-Stylesheet einen png-Fix eingebaut. Je nach Anzahl der .png Bildchen müssen dadurch anscheinend diese Bildchen nochmal nachgeladen werden. Der Browsercache kommt da wohl nicht zum Einsatz...

Man muss sich also entscheiden:
- entweder kein png-fix und dadurch evtl. falsche Anzeige der .png-Bilder im ie6
- oder mit dem nachladen im ie6 leben


Um den png-Fix abzuschalten legt man im Ordner /layout/style/ eine neue .css Datei mit dem Namen custom_pngfix.css, mit folgendem Inhalt an:img, div, input, .png, .pngfix {
   behavior: none;
}
Diese Datei wird vom default-Stylesheet automatisch eingelesen und die css-Eigenschaft wird überschrieben...

Danach dürfte das Nachladen nicht mehr vorkommen.
Hier auf unserer Seite habe ich das mal probehalber gemacht und es scheint zu funzen...


EDIT:
- damit sich die Änderungen auswirken, muss entweder der pragmaMx Cache abgeschaltet sein, oder muss dieser geleert werden.

- der Code zum abschalten kann etwas optimiert werden:
img, div, input {
   behavior: none;
}
So werden zumindest noch die expliziet formatierten .png-Bildchen korrekt angezeigt
« Letzte Änderung: 13 Mai 2009, 02:09:34 von Andi »
schön´s Grüssle, Andi

Offline powerline

  • ***
  • 121
  • +1/-5
  • Geschlecht: Männlich
also erstmal vielen Dank für Eure Tipps.
Besonders an die Ausarbeitung von Andi :thumbup:

Ich hätte mir nicht träumen lassen das das mit dem IE7 so viel ausmacht.
Ich habe mich natürlich für die Installation des IE7 entschlossen.
Unterschied wie Tag und Nacht.

Vielen Dank

Gruß Michael