pragmaMx Support Forum pragmaMx Support Forum

Nach Update auf 0.1.10 kein Spaw mehr

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Sleppy

  • *
  • 7
  • +0/-1
  • Geschlecht: Männlich
Nach Update auf 0.1.10 kein Spaw mehr
« am: 05 Februar 2008, 01:32:47 »
Hy ihr,
habe gerade das neue Update rübergezogen, soweit alles bestens.
Nur wenn ich einen Artikel oder ähnliches erstellen will, wo ich den Spaw-Editor brauche, zeigt er mir nur Fehler an. Der Spaw-Editor nutzt bei mir die Server-Adresse "/homepages/634934784/......" anstatt der www.-Adresse
Damit findet er nicht die Grafiken vom Spaw-Editor.

Wo kann ich dies ändern, damit er wieder funzt.

Gruss Sleppy

Offline PhanThomas

  • **
  • 34
  • +0/-0
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #1 am: 05 Februar 2008, 09:27:26 »
Hi habe ähnliches Problem,

eben Update installiert. Kurz vor Ende des Updates wollte die Installationsroutine Dateien löschen (viele davon von Spaw) welches fehlschlug aber dringend empfohlen wurde. Dies schlug leider fehl. Daher habe ich sie dann manuell gelöscht und auf wiederholen gedrückt. Ok eine Datei hatte ich da übersehen. Schnell diese auch noch gelöscht und nochmal auf wiederholen geklickt - und alles bestens....
Bis ich dann versuche auf Module zuzugreifen die Spaw nutzen. Sehe dann immer nur leer Seite und nichts geht mehr  :puzzled:

Gruß Tom

Offline insanehsp

  • **
  • 66
  • +2/-0
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #2 am: 05 Februar 2008, 11:42:40 »
Hy ihr,
habe gerade das neue Update rübergezogen, soweit alles bestens.
Nur wenn ich einen Artikel oder ähnliches erstellen will, wo ich den Spaw-Editor brauche,
zeigt er mir nur Fehler an. Der Spaw-Editor nutzt bei mir die Server-Adresse
"/homepages/634934784/......" anstatt der www.-Adresse
Damit findet er nicht die Grafiken vom Spaw-Editor.

Wo kann ich dies ändern, damit er wieder funzt.

Gruss Sleppy

Nach einem scheinbar sauberen Update, musste ich heute auch feststellen das der Spaw Editor nicht bei mir funktioniert. Anhand der Grafiken sehe ich das er auf einmal so verlinkt ist:

http://45168.vs.webtropia.com/C:/Inetpub/vhosts/45168.vs.webtropia.com/ httpdocs/php/spaw/plugins/core/lib/theme/spaw2/img/tb_inserthorizontalrule.gif

Originaler Root ist bei mir: http://45168.vs.webtropia.com/php    ... hm.. vielleicht wieder ein Problem mit Windows-Server ?

Bei der 0.1.9.1 konnte man da noch in der Editor_cnf.php einen Pfad eingeben
Werde zum Hörspielsprecher: Hoerspielprojekt.de
ODER
Besuche das Hörspiel-Forum: Hoertalk.de


Offline Michi_A

  • *
  • 16
  • +0/-1
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #3 am: 05 Februar 2008, 13:12:58 »
Selbes Problem. Install Routine lief sauber. Aber der Spaw Editor läuft in keinster weise, leider.
http://www.fucktor-x.com/spaw/demo/demo.php

Ich denk mal der Pfad ist falsch. Zeigt bei mir www.homepages an.

Hoffe auf baldige Lösung.
 :smile:


MfG

Michael Hoffmann

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #4 am: 05 Februar 2008, 15:08:21 »
Hoi :)

der neue Spaw ermittelt seine benötigten Ordner und URL's automatisch. Während den Betatests hat das auch auf allen Servern einwandfrei funktioniert.
Es ist aber durchaus möglich, dass versch. Server da nicht mitspielen, leider fehlte uns da aber die Möglichkeit zum testen...

Auch den Entwicklern des Spaw ist das Problem anscheinend bekannt und sie haben Vorbereitungen getroffen:
http://www.spaweditor.com/spaw/spaw2/docs/documentation/integrators.html

Zitat
Path Related Settings

These settings determine locations SPAW uses to load it's files. These are automatically calculated in most instances, but if you get errors in demo script or can't see button images, etc. this is where the problem most likely is.


DOCUMENT_ROOT
Specifies a file system path to the root directory of your website. On most Apache/PHP installations this is calculated automatically

SPAW_ROOT
Specifies a file system path to the SPAW directory. Automatically calculated.

SPAW_DIR
Specifies a path from web site root to the SPAW directory, that is if you access demo script by pointing your browser to http://mydomain.com/spaw/demo/demo.php SPAW_DIR should be set to '/spaw/'. Automatically calculated

Konkret, würde das heissen, dass man die /spaw/config/config.php manuell anpassen kann, um das Problem zu lösen. Es handelt sich um folgende komplett auskommentierte Zeilen:

/*
// semi-automatic path calculation
// comment the above settings of DOCUMENT_ROOT, SPAW_ROOT and SPAW_DIR
// and use this block if the above fails.
// set SPAW_DIR manually. If you access demo page by http://domain.com/spaw2/demo/demo.php
// then set SPAW_DIR to /spaw2/
SpawConfig::setStaticConfigItem('SPAW_DIR', '/spaw2/');
// and the following settings will be calculated automaticly
SpawConfig::setStaticConfigItem('SPAW_ROOT', str_replace("\\","/",realpath(dirname(__FILE__)."/..").'/'));
SpawConfig::setStaticConfigItem('DOCUMENT_ROOT', substr(SpawConfig::getStaticConfigValue('SPAW_ROOT'),0,strlen(SpawConfig::getStaticConfigValue('SPAW_ROOT'))-strlen(SpawConfig::getStaticConfigValue('SPAW_DIR'))));
*/

/*
// under IIS you will probably need to setup the above paths manually. it would be something like this
SpawConfig::setStaticConfigItem('DOCUMENT_ROOT', 'c:/inetpub/wwwroot/');
SpawConfig::setStaticConfigItem('SPAW_ROOT', 'c:/inetpub/wwwroot/spaw2/');
SpawConfig::setStaticConfigItem('SPAW_DIR', '/spaw2/');
*/

Wie und was man da jetzt bei den einzelnen Servern einstellen muss kann ich so pauschal nicht sagen.
Probiert doch mal und berichtet....

Wenn nicht, dann gebt mir mal einer von Euch nen Admin u. FTP-Zugang, dass ich das selbst probiere...


PS:
Im Spaw Forum gibt es etliche Einträge zu dem Thema, einfach dort mal nach SPAW_ROOT suchen.
z.B.: http://forums.solmetra.com/viewtopic.php?t=7965&highlight=spawroot


PS2:
diese config.php kann  insgesamt komplett individuell angepasst werden, so wie in der Anleitung beschrieben. Bei evtl. Updates von pragmaMx wird die dann nicht mehr mitgeliefert, so dass eigene Änderungen nicht überschrieben werden.
« Letzte Änderung: 05 Februar 2008, 15:28:03 von Andi »
schön´s Grüssle, Andi

Offline Wonkodv

  • ***
  • 127
  • +0/-1
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #5 am: 05 Februar 2008, 15:40:11 »
Moin moin,

in meinem FAll ist das nicht wirklich dramatisch

Zitat
/*

// semi-automatic path calculation

// comment the above settings of DOCUMENT_ROOT, SPAW_ROOT and SPAW_DIR

// and use this block if the above fails.

// set SPAW_DIR manually. If you access demo page by http://domain.com/spaw2/demo/demo.php

// then set SPAW_DIR to /spaw2/*/

SpawConfig::setStaticConfigItem('SPAW_DIR', '/spaw/');

// and the following settings will be calculated automaticly

SpawConfig::setStaticConfigItem('SPAW_ROOT', str_replace("\\","/",realpath(dirname(__FILE__)."/..").'/'));

SpawConfig::setStaticConfigItem('DOCUMENT_ROOT', substr(SpawConfig::getStaticConfigValue('SPAW_ROOT'),0,strlen(SpawConfig::getStaticConfigValue('SPAW_ROOT'))-strlen(SpawConfig::getStaticConfigValue('SPAW_DIR'))));





/*

// under IIS you will probably need to setup the above paths manually. it would be something like this

SpawConfig::setStaticConfigItem('DOCUMENT_ROOT', 'c:/inetpub/wwwroot/');

SpawConfig::setStaticConfigItem('SPAW_ROOT', 'c:/inetpub/wwwroot/spaw2/');

SpawConfig::setStaticConfigItem('SPAW_DIR', '/spaw2/');

*/

hier muß nur im oberen Bereich auskommentiert werden, in der unterstrichenen Zeile  /spaw2/ ändern in /spaw/,
da der Ordner unter spaw abgelegt wurde.

Gruß

Olaf

Offline Michi_A

  • *
  • 16
  • +0/-1
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #6 am: 05 Februar 2008, 15:48:11 »
Tach,
in meinem Fall funzt das leider nicht.

Hab Andi die Zugangsdaten geschickt und hoffentlich wird das wieder.

MfG

Offline Mecki

  • *******
  • 1.239
  • +1/-0
  • Geschlecht: Männlich
  • Mecki
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #7 am: 05 Februar 2008, 16:43:25 »
Danke,

für die Info, hatte das gleiche Problem, funzt jetzt  :thumbup:

LG
Mecki
Nicht behindert zu sein, ist kein Verdienst, sondern ein Geschenk, das uns jederzeit genommen werden kann.

maverik

Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #8 am: 05 Februar 2008, 17:27:15 »
hiho

ich habe mir kurz vor ende des betatests linux im dualboot zum xp installiert. dort einen kompletten apachen mit php, mysql etc eingerichtet und ein beta pragma installiert.

in dieser installation hatte ich die gleichen probleme mit dem spaw wie hier beschrieben, da ich mir nicht sicher war ob das problem nun mit meinen noch geringen linux kenntnissen oder mit dem spaw selber zu tun hatte habe ich dazu nichts geschrieben.

ich habe jetzt die hier beschriebenen anpassungen

// semi-automatic path calculation
// comment the above settings of DOCUMENT_ROOT, SPAW_ROOT and SPAW_DIR
// and use this block if the above fails.
// set SPAW_DIR manually. If you access demo page by http://domain.com/spaw2/demo/demo.php
// then set SPAW_DIR to /spaw2/
SpawConfig::setStaticConfigItem('SPAW_DIR', '/spaw2/');
// and the following settings will be calculated automaticly
SpawConfig::setStaticConfigItem('SPAW_ROOT', str_replace("\\","/",realpath(dirname(__FILE__)."/..").'/'));
SpawConfig::setStaticConfigItem('DOCUMENT_ROOT', substr(SpawConfig::getStaticConfigValue('SPAW_ROOT'),0,strlen(SpawConfig::getStaticConfigValue('SPAW_ROOT'))-strlen(SpawConfig::getStaticConfigValue('SPAW_DIR'))));

vorgenommen und hier den pfad

SpawConfig::setStaticConfigItem('SPAW_DIR', '/spaw2/');
so geändert

Zitat
SpawConfig::setStaticConfigItem('SPAW_DIR', 'spaw/');

jetzt läuft der spaw auch auf meiner lokalen installation.


so long maverik

####################

edit:

ich muss wohl doch noch etwas mit den einstellungen testen da ich grade festgestellt habe das die buttons wie link einfügen, bild einfügen etc noch nicht funktional sind.

fortsetzung folgt
« Letzte Änderung: 05 Februar 2008, 17:39:26 von maverik »

Offline insanehsp

  • **
  • 66
  • +2/-0
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #9 am: 05 Februar 2008, 17:57:26 »
Danke für Info Andi, anhand der Pfad-Variablen konnte ich es soweit anpassen das der Spaw Editor nun funktioniert (auch Buttons) :) ... Damit ist wieder alles beim alten nach dem Update
Werde zum Hörspielsprecher: Hoerspielprojekt.de
ODER
Besuche das Hörspiel-Forum: Hoertalk.de


maverik

Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #10 am: 05 Februar 2008, 18:15:24 »
@isanehsp

könntest du vielleicht mal deine anpassungen posten, bei mir klemmt noch ein pfad, maybe kann man da durch vergleichen etwas herausbekommen

thx


Offline PhanThomas

  • **
  • 34
  • +0/-0
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #11 am: 05 Februar 2008, 18:28:58 »
Tja schade, bei mir hat die einfache Pfadanpassung nicht geklpappt. Wo kann ich den Spaw aussschalten, damit ich wenigsten jetzt mal normal weiterarbeiten kann?

Thanx & Hellau

Offline Adapter

  • **
  • 41
  • +0/-0
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #12 am: 05 Februar 2008, 18:36:12 »
Also Anpassung geht hier auch nicht,
Spaw Editor ist da nur Java scheint nicht zu gehen Hintergrund und Schalter sind da.

Gruß Adapter
CMS-Version:        pragmaMx 0.1.10,
PHP-Version:    4.4.7  (PHP-Info)
MySQL-Version:  5.0.45-community-log
Server-Version:         Apache/1.3.39 (Unix)
Ausserdem bei http://kanotix.com aktiv

Offline Biker

  • *******
  • 1.609
  • +4/-29
  • Geschlecht: Männlich
    • Privat- u. Wirtschaftsdetektei Martin
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #13 am: 05 Februar 2008, 18:39:29 »
Habe das gleiche Problem auf dem 1&1 Server....nicht auf biker-unity.de!!!...auf einer Testseite!

Also die Anpassung bezüglich der Grafiken habe ich hinbekommen, aber wenn ich z.B. die "Blöcke-Einstellungen" im Admin-Menü aufrufe, erhalte ich den Fehler "SpawEngine undefiniert" Zeile 369 Code 1

Wenn ich einen Artikel schreiben will...also Artikel erstellen...erhalte ich die Fehlermeldung
"SpawEngine undefiniert" Zeile 279 Code: 0 Zeichen: 1
"SpawEngine undefiniert" Zeile 291 Code: 0 Zeichen: 1
und der Editor wird gar nicht angezeigt!

Gruß
Bernd
« Letzte Änderung: 05 Februar 2008, 18:44:55 von Biker »
Detektei Martin - wir bringen Licht ins Dunkle!

Offline bruegge

  • *
  • 3
  • +0/-0
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #14 am: 05 Februar 2008, 18:44:36 »
Hi,
ebenfalls gleiches Problem auf 1&1 Server.....

Bei mir erscheint nach kurzer Wartezeit die Google-Suche.

Hilfe!!

Offline steina

  • *
  • 9
  • +0/-0
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #15 am: 05 Februar 2008, 19:04:36 »
Hallo,
Einstellungen wie vorgeschlagen habe ich durchgeführt, leider kein positives Ergebnis.

http://www.cika.de/spaw/demo/demo.php

Kann da jemand helfen, sende auch meine FTP-Daten.

Gruss
Georg

Offline Biker

  • *******
  • 1.609
  • +4/-29
  • Geschlecht: Männlich
    • Privat- u. Wirtschaftsdetektei Martin
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #16 am: 05 Februar 2008, 19:13:58 »
Tja schade, bei mir hat die einfache Pfadanpassung nicht geklpappt. Wo kann ich den Spaw aussschalten, damit ich wenigsten jetzt mal normal weiterarbeiten kann?

Thanx & Hellau

Schalte im Admin-Menü den Wysiwyg-Editor aus....dann kannste "normal weiter arbeiten"!
Gruß
Bernd
Detektei Martin - wir bringen Licht ins Dunkle!

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #17 am: 05 Februar 2008, 20:05:42 »
Moin :)

ich weiss ja nicht, was und vor allem wie ihr die entsprechenden Zeilen geändert habt, aber bei Michi_A hat das eben sofort funktioniert und das scheint auch ein 1&1 Server zu sein...

http://www.fucktor-x.com/spaw/demo/demo.php


Um etwas, was auskommentiert ist, wieder einzukommentieren, muss man natürlich die Kommentarzeichen drumrum entfernen: http://de2.php.net/manual/de/language.basic-syntax.comments.php

Sprich, diese Zeichen /* und */ um den entsprechenden Codeblock müssen weg.
Dann noch den Ordnernamen von /spaw2/ zu /spaw/ umbenennen und schon geht es...

Konkret würde das dann so wie auf dem beigefügten Screenshot aussehen.
Angezeigt in Beyond-Compare umd en Unterschied zum Original zu zeigen...
schön´s Grüssle, Andi

Offline Mecki

  • *******
  • 1.239
  • +1/-0
  • Geschlecht: Männlich
  • Mecki
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #18 am: 05 Februar 2008, 20:09:04 »
Hi,

ich bestätige es noch mal, bei mir hat es auch geklappt. Ich bin allerdings nicht bei 1&1 , sondern nutze ein kostenloses Webspacepaket mit "Subdomain" zum testen.

LG
Mecki
Nicht behindert zu sein, ist kein Verdienst, sondern ein Geschenk, das uns jederzeit genommen werden kann.

Offline Biker

  • *******
  • 1.609
  • +4/-29
  • Geschlecht: Männlich
    • Privat- u. Wirtschaftsdetektei Martin
Re: Nach Update auf 0.1.10 kein Spaw mehr
« Antwort #19 am: 05 Februar 2008, 20:43:12 »
Tja...ich habs genauso gemacht, aber bei mir kommt das hier:
http://pmx.chinese-sharpei.de/spaw/demo/demo.php
Zitat
This is not a feature demonstration of SPAW Editor. This script is included for the only purpose of testing your configuration. If you can see and operate an instance of SPAW Editor below then your editor is properly configured

For extended feature demonstration visit our demo page at solmetra.com

Als Fehlermeldung erhalte ich jetzt plötzlich das hier:
SpawThemeSpaw ist undefiniert

Kann evtl. mal jemand ne funktionierende config.php anhängen?
Detektei Martin - wir bringen Licht ins Dunkle!