pragmaMx Support Forum pragmaMx Support Forum

Umfrage

unter welcher PHP-Version läuft eure pragmaMx Installation?

kleiner als 4.2
0 (0%)
zwischen 4.2.0 und 4.2.3
1 (0.8%)
zwischen 4.3.0 und 4.3.11
28 (21.1%)
ab 4.4.0 aber kein 5.x
42 (31.6%)
zwischen 5.0.0 und 5.0.5
9 (6.8%)
zwischen 5.1.0 und 5.1.6
7 (5.3%)
ab 5.2.0
46 (34.6%)
sonstige (welche?)
0 (0%)

Stimmen insgesamt: 110

UMFRAGE: eingesetzte PHP-Versionen

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
UMFRAGE: eingesetzte PHP-Versionen
« am: 29 Juli 2007, 11:17:07 »
Für die weitere Entwicklung von pragmaMx, müssten wir mal wissen, auf welchen PHP-Versionen, euer pragmaMx hauptsächlich läuft.
Wenn ihr verschiedene Versionen auf eurem Server/Hosting einstellen könnt, dann nennt bitte die höchst Mögliche Version.


Die Information findet ihr ganz leicht, wenn ihr im pragmaMx-Adminhauptmenü, etwas nach unten scrollt...

Zitat
CMS-Version:     pragmaMx 0.1.9, 1.30/2007-04-05     
PHP-Version:    4.4.6  (PHP-Info)
MySQL-Version:    4.1.22-standard
Server-Version:    Apache/***

Bitte die Version nicht hier reinschreiben, sondern in den Umfrageoptionen ankreuzen!
« Letzte Änderung: 29 Juli 2007, 15:06:27 von Andi »
schön´s Grüssle, Andi

Offline HanSolo

  • ****
  • 475
  • +5/-6
  • Geschlecht: Männlich
Re: eingesetzte PHP-Versionen
« Antwort #1 am: 29 Juli 2007, 13:05:44 »
Hallo Andi,

das finde ich gut, dass ihr nach der Entscheidung auf 5.2 umzustellen diese Abfrage macht; es wäre allerdings auch schön, wenn es eine Art Übersicht geben würde, wenn man eben die Möglichkeit hat, mehrere Versionen laufen zu lassen, ob ein Umstellen problemlos möglich ist, oder welche Module da ggf. Probleme machen könnten. Denn einfach mal so umzuschalten kann ja mit Problemen verbunden sein, oder?

Vielleicht gibt es ja da eine Info drüber.

Ansonsten - ich freue mich auf PMX 2

Lieben Gruß
Oliver / HanSolo

PS
Habe php 4.4.4 und die Möglichkeit auf 5.1.6 - und daher auch der obige Sermon :)
Lieben Gruß

Oliver / HanSolo

Offline Metal-Overdrive

  • ****
  • 273
  • +1/-0
  • Geschlecht: Männlich
Re: eingesetzte PHP-Versionen
« Antwort #2 am: 29 Juli 2007, 13:17:37 »
Zitat
CMS-Version:     pragmaMx 0.1.9, 1.30/2007-04-05     
PHP-Version:    5.2.1  (PHP-Info)
MySQL-Version:    5.0.27-max-log
Server-Version:    Apache

Edit: Argh, hab die Umfrage gar nicht gesehen...

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: eingesetzte PHP-Versionen
« Antwort #3 am: 29 Juli 2007, 14:21:07 »
Hi :)

Zitat
Denn einfach mal so umzuschalten kann ja mit Problemen verbunden sein, oder?

pragmaMx und die anderen Scripte von uns, werden komplett auf PHP5 entwickelt.
Die aktuellen Versionen sind also zu 100% mit PHP5 kompatibel.


Ein Umschalten auf PHP5 dürfte keinerlei Probleme verursachen.
Für Fremdarbeiten kann ich da natürlich nix sagen....


Ich empfehle jetzt schon die Umstellung auf PHP5.x.
schön´s Grüssle, Andi

Offline cihan

  • *****
  • 638
  • +3/-2
  • Kurdistan
Re: eingesetzte PHP-Versionen
« Antwort #4 am: 29 Juli 2007, 14:45:39 »
Zitat
CMS-Version:         pragmaMx 0.1.9, 1.30/2007-04-05     
PHP-Version:         4.3.10  (PHP-Info)
MySQL-Version:     4.1.10a
Server-Version:      Apache/**

Offline moskote01

  • ***
  • 135
  • +0/-0
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #5 am: 29 Juli 2007, 15:08:31 »
hallo

genauer
PHP-Version:5.0.4
MySQL-Version: 4.0.24_Debian-10sarge2-log

MfG
Techno & Hiphop Events aus Berlin
docsexlin.de

Offline erast

  • *
  • 13
  • +0/-0
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #6 am: 29 Juli 2007, 15:10:33 »
Hatte gerade letzte Woche ein Mail von unserem Provider. 

PHP5 wird ab August07 als Standard auf dem Server aktiviert.

PHP4 wird ab Dezember07 auch als Option ausgeschaltet . Dann
nur noch PHP5.

Hoffentlich kommt das gut.  ;)

gruss

erast

Offline Future

  • *******
  • 1.689
  • +0/-0
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #7 am: 29 Juli 2007, 15:32:26 »
Moin Andi,

auch von mir etwas genauer

PHP-Version:   5.2.0-8+etch7
MySql-Version:   5.0.32-Debian_7etch1-log
Server:   Apache/2.2.3 (Debian :thumbup:)

Offline vb

  • ***
  • 228
  • +0/-1
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #8 am: 29 Juli 2007, 21:03:08 »
Da hab ich wohl die neueste.  :heu:

Zitat
PHP-Version:    5.2.3-0.dotdeb.0
« Letzte Änderung: 29 Juli 2007, 21:07:39 von vb »
      


         Mit freundlichen Grüßen


      


         VB

   _____________________________________________


      


         Folgende CMS im Einsatz: 2F CMS, pragmaMX

         Wer clever ist wir sich das hier genauer ansehen.


Offline funowner

  • **
  • 47
  • +0/-1
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #9 am: 29 Juli 2007, 22:23:38 »
Ich hab 5.0.4

Etwas veraltet oder egal?
Lebe dein Leben solange du es kannst!

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #10 am: 30 Juli 2007, 18:25:54 »
Hi Andi,
nur so zur Info auf meinem Server läuft seit heute die PHP-Version: 5.0.5
Ich habe Gestern aber noch "zwischen 4.3.0 und 4.3.11" gewählt, da ich das heute erst selbst erfahren habe.

Offline all-it-web-de

  • *
  • 12
  • +1/-0
  • Geschlecht: Männlich
  • VISTA Stirb langsam 4.0
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #11 am: 31 Juli 2007, 01:44:38 »
Ich hab 5.0.4

Etwas veraltet oder egal?

Meiner Meinung nach eine bomben-stabile Angelegenheit - sowohl auf 32 als auch 64bit.

PHP4 ist bei unseren Servern schon seit Ewigkeit gar nicht mehr mit drauf, und sollte ein
Kunde noch sein Zeug auf php4-Basis programmiert haben, gibt's da SUPER Möglichkeiten seinen php4-code dann 5.x.x fähig zu machen, ohne dass er selber was umprogrammieren muss.

Offline jogi24

  • *******
  • 2.417
  • +5/-2
  • Geschlecht: Männlich
  • altes Eisen stark verrostet
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #12 am: 31 Juli 2007, 11:39:00 »
hi
@ all-it-web-de

sollte ein
Kunde noch sein Zeug auf php4-Basis programmiert haben, gibt's da SUPER Möglichkeiten seinen php4-code dann 5.x.x fähig zu machen, ohne dass er selber was umprogrammieren muss.

gieb mal bitte infos über solche möglichkeiten.

ist bestimmt für viele von nutzen.  ;) ;)

Offline all-it-web-de

  • *
  • 12
  • +1/-0
  • Geschlecht: Männlich
  • VISTA Stirb langsam 4.0
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #13 am: 31 Juli 2007, 12:39:50 »
Hallo jogi,

bei den meisten hat es schon geholfen diverse Systemvariablen, die unter php4 noch umständlich lang formuliert waren, z.B. gleich in seiner index.php "umschreiben" zu lassen wie zum Bleistift:

Zitat
$HTTP_POST_VARS   = !empty($HTTP_POST_VARS)   ? $HTTP_POST_VARS   : $_POST;
$HTTP_GET_VARS    = !empty($HTTP_GET_VARS)    ? $HTTP_GET_VARS    : $_GET;
$HTTP_COOKIE_VARS = !empty($HTTP_COOKIE_VARS) ? $HTTP_COOKIE_VARS : $_COOKIE;
$HTTP_SERVER_VARS = !empty($HTTP_SERVER_VARS) ? $HTTP_SERVER_VARS : $_SERVER;
$HTTP_SESSION_VARS = !empty($HTTP_SESSION_VARS) ? $HTTP_SESSION_VARS : $_SESSION;

Waren natürlich diverse funktionen gecoded, die unter php5 anders oder sicherer zu programmieren waren im spiel, musste man da halt noch mal Hand anlegen.

Aber in den meisten Fällen war das kein großer Akt mehr.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #14 am: 07 August 2007, 02:23:00 »
Hi :)

die besagten Variablen stehen auch unter PHP-5 zur Verfügung, wenn man in der php.ini die Option register_long_arrays auf ON stellt. Das ist auch kein PHP-5 spezifisches Ding, sondern die Option steht schon (ich glaube) seit PHP-4.3 standardmässsig auf OFF.
Und ehrlich, Scripte, die diese Arrays noch zwingend benötigen, gehören eh vom Server geworfen....


Aber zurück zum Thema, wir haben doch mehr als 40 User hier.

Was habt ihr am laufen ? ?? ? ? ?



PS: nur die entsprechende PHP-Version ankreuzen, alles andere ist egal, weitere Details sind nicht nötig.
schön´s Grüssle, Andi

Offline hausmeista

  • **
  • 92
  • +2/-0
  • Geschlecht: Männlich
  • demoview.de
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #15 am: 22 August 2007, 00:05:31 »
PHP-Version:  5.0.4 (PHP-Info)
MySQL:          4.1.13
Server:          Apache/2.0.54 (Linux/SUSE)
Heiko Richter: In Deutschland muss man arbeiten wie ein Pferd um zu verdienen wie ein Pony.
PMX Shop-Modul unter www.vcardo.de

Offline dustybrother

  • *
  • 4
  • +0/-0
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #16 am: 22 August 2007, 07:33:31 »
PHP-Version:     4.4.7

Offline seleck

  • ****
  • 356
  • +0/-3
  • Geschlecht: Männlich
  • Don't confuse elegance with snobbery.
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #17 am: 03 September 2007, 11:06:51 »
Zitat
Ich hab 5.0.4

Etwas veraltet oder egal?

Hallo leute übertreibt nicht so hoch. Ich bin beim all-inkl.de und meine einige Seiten laufen von Version4.4.4 bis Version 5.0.4.

Natürlich sollte man  aufs neuestem Stand sein, aber man sollte nicht mit dem Hammer darauf hauen.

Grüße
If I advance, follow me.
If I stop, push me.
If I fall, inspire me.

Offline Andi

  • *****
  • 18.832
  • +4/-0
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #18 am: 03 September 2007, 11:28:21 »
Jop, da werden sich etliche Hoster in nächster Zeit umguggen, wenn aktuelle Software nicht mehr auf deren Servern läuft....
Aktuell ist PHP 5.2.4, alles was unter 5.2.x ist, kann man als veraltet bezeichnen.

Wenn man die Liste so durchguggt, was da alles dabei ist....
http://gophp5.org/projects

- Gallery
- phpMyAdmin
- Pear
- PHPUnit
- Symfony
- Typo3
- Drupal

Da ist unser pragmaMx nur ein gaaaanz kleines unbekanntes Licht in der Liste ;)

PS: die aktuelle CVS-Entwicklerversion von pragmaMx läuft schon nicht mehr unter PHP 4.x
schön´s Grüssle, Andi

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: UMFRAGE: eingesetzte PHP-Versionen
« Antwort #19 am: 03 September 2007, 20:31:12 »
PS: die aktuelle CVS-Entwicklerversion von pragmaMx läuft schon nicht mehr unter PHP 4.x
Hi Andi,
kannst du dazu schon nähere Angaben machen?
Ob nur PHP 4.x oder auch ältere PHP 5.x?