pragmaMx Support Forum pragmaMx Support Forum

Frage zu: Postausgang Fehler und Verbesserungsvorschläge

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Bebekcik

  • **
  • 50
  • +0/-0
  • Geschlecht: Männlich
Hallo,

Habe jetzt das neueste Paket draufgemacht und folgender fehler beim abgespeichertem PM s im Postausgang:



Ziehmlich viele symbole :) Vielleicht ist es aber bekannt...

Hallo, wollte mal nachfragen ob dieses problem schon gelöst worden ist.

Offline David555

  • ***
  • 167
  • +2/-0
  • Geschlecht: Männlich
Frage zu: Postausgang Fehler und Verbesserungsvorschläge
« Antwort #1 am: 09 Juli 2007, 21:04:30 »
Meines wissens noch nicht. Schaue gerade, ob ichs hinbekomme. Aber ist verdammt schwer, wenn man in fremden oder eben nicht in seinem eigenen Script nach Fehlern sucht.
Wer aufräumt ist zu faul zum suchen!

Offline jogi24

  • *******
  • 2.417
  • +5/-2
  • Geschlecht: Männlich
  • altes Eisen stark verrostet
Frage zu: Postausgang Fehler und Verbesserungsvorschläge
« Antwort #2 am: 09 Juli 2007, 21:08:58 »
hi

@ all

nein noch nicht  :puzzled:

wenn ihr das modul nutzen wollt, und euch die blättchen stören, was mich auch nervt,
dann schaltet in den einstellungen

Private Nachrichten der Benutzer regelmässig abfragen:

ab.

auf null setzen.

ist zwar noch keine lösung, aber damit sind erstmal die blätter wech. ;)

Offline jogi24

  • *******
  • 2.417
  • +5/-2
  • Geschlecht: Männlich
  • altes Eisen stark verrostet
Frage zu: Postausgang Fehler und Verbesserungsvorschläge
« Antwort #3 am: 09 Juli 2007, 21:25:26 »
hi

@  David555

vieleicht hilft dir das was ich bis jetzt lokalisiert habe

im table _priv_msgs_send wird unter read_msg keine 1 gesetzt  (gelesen)
es bleibt immer bei der 0


leider reichen meine datenbank-kenntnisse auch nicht so weit, damit ich es fixen kann  :smile:

Offline GerhardSt

  • ******
  • 1.035
  • +4/-3
  • Geschlecht: Männlich
Re: Postausgang Fehler und Verbesserungsvorschläge
« Antwort #4 am: 09 Juli 2007, 22:04:13 »
Hallo jogi24,
in der Tabelle _priv_msg_send braucht du die Zeile read_msg nicht mehr. Die Abfrage wird von der Tabelle _priv_msg gemacht.

Für alle die versuchen wollen den Fehler zu beheben: Er muß irgendwo in der index.php ab Zeile 680 sein!
« Letzte Änderung: 09 Juli 2007, 22:24:28 von GerhardSt »

Offline David555

  • ***
  • 167
  • +2/-0
  • Geschlecht: Männlich
Re: Frage zu: Postausgang Fehler und Verbesserungsvorschläge
« Antwort #5 am: 09 Juli 2007, 22:45:38 »
hi

@  David555

vieleicht hilft dir das was ich bis jetzt lokalisiert habe

im table _priv_msgs_send wird unter read_msg keine 1 gesetzt  (gelesen)
es bleibt immer bei der 0


leider reichen meine datenbank-kenntnisse auch nicht so weit, damit ich es fixen kann  :smile:

Das hatte ich auch bemerkt und wunderte mich. Habe dort die 0 zu einer 1 umgeschrieben, aber das hatte nichts gebracht. Daher dachte ich, dass es daran wohl nicht liegen kann.

Was mir noch aufgefallen ist, wenn man die while Schleife ein wenig verändert (Zeile 734), wird die Ausgabe immer nur in der letzten PM ausgegeben (Ich mein alle Zutreffer der Abfrage if ($row1["read_msg"] == 1)). Und das wundert mich, obwohl die if Abfrage in der Schleife bei jeder PM abgefragt wird. Naja, ich werd ma weiterschauen  ;)
Wer aufräumt ist zu faul zum suchen!

Offline David555

  • ***
  • 167
  • +2/-0
  • Geschlecht: Männlich
Re: Frage zu: Postausgang Fehler und Verbesserungsvorschläge
« Antwort #6 am: 10 Juli 2007, 00:26:23 »
Jetzt merk ichs erst, das ist ja ein neues Thema, mit fast dem gleichen Namen. Da hat Andi natürlich recht, sehr verwirrend! Dieses Thema sollte wieder geschlossen werden, werde im "normalen" weiter machen.
Wer aufräumt ist zu faul zum suchen!