pragmaMx Support Forum

pragmaMx => Installation & Update => Thema gestartet von: Uli2003 am 21 November 2018, 20:47:16

Titel: Kategorie-Manager der Coppermine unter PHP 7.1
Beitrag von: Uli2003 am 21 November 2018, 20:47:16
Hallo zusammen,

bei mir läuft recht anstandslos seit Jahren die Coppermine Galerie. Updates immer alle gemacht, auch die Bridge.

Unter PHP 7.1 (7.0 ebenso) bekomme ich im Kategorienmanager allerdings folgende Fehlermeldung:

Es sind Probleme bei der Seitenerstellung aufgetreten.
Fatal error: Uncaught exception:
[] operator not supported for strings (code: 0)
in modules/Gallery/catmgr.php on line 78

Keine Ahnung wie lange das schon so ist, ich selbst stelle keine Bilder ein, denke aber mal seit Umstellung auf PHP 7, da ich bisher nichts gehört habe.
Ich habe auf 7 umgestellt, da der extended Support für 5.6 ab Dezember Geld kostet..

Gibt es dafür einen Fix?
Titel: Re: Kategorie-Manager der Coppermine unter PHP 7.1
Beitrag von: Uli2003 am 21 November 2018, 22:22:44
Ich habe jetzt einmal, um die Fehlerausgabe zu beheben, die Variable $CAT_LIST in der Funktion als Array initiiert.


Der Menüpunkt 'Kategorien' läuft wieder, es können auch wieder Kategorien angelegt werden. Leider wird in der Kategorieübersicht nur noch eine Kategorie angezeigt. Mit meiner rudimentären PHP-Kenntnis muss ich mich wohl noch etwas mit der Materie befassen :)


Für eine solide Lösung wäre ich dankbar.

Grüße
Uli

Titel: Re: Kategorie-Manager der Coppermine unter PHP 7.1
Beitrag von: TerraProject am 22 November 2018, 09:14:42
prinzipiell ist die CPG immer noch nicht PHP7-ready, auch die derzeit aktuelle Originalversion von der CPG 1.5.x, (http://coppermine-gallery.net/) erst ab der Version 1.6. soll wohl eine PHP7-Tauglichkeit da sein. Auf Grund des hohen Aufwandes, die CPG in pmx zu integrieren, haben wir uns entschlossen, diese Bridge nicht mehr weiter zu entwickeln. Alternativ kann die SiriusGallery verwendet werden, die auch die Bilder aus der CPG importieren kann.
Titel: Re: Kategorie-Manager der Coppermine unter PHP 7.1
Beitrag von: Uli2003 am 23 November 2018, 15:15:22
Die CPG läuft aber recht problemlos unter PHP7, abgesehen vom CAT-Manager und der Diashow.
Daher werde ich mal versuchen das Problem zu beheben, wenn ich mal irgendwann Zeit habe.