pragmaMx Support Forum

pragmaMx => Installation & Update => Thema gestartet von: Fokuna2 am 20 Februar 2018, 18:56:30

Titel: Sirius Gallery funktioniert nicht bei PHP 7.2.2
Beitrag von: Fokuna2 am 20 Februar 2018, 18:56:30
Ich habe gerade festgestellt, das die SiriusGallery  nicht funktioniert, wenn man  PHP 7.2.2 benutzt,
Da kommt folgende Fehlermeldung:

Zitat
PHP Deprecated warning:
Function create_function() is deprecated
in includes/mx_api.php on line 2228

anscheinend wird diese Funktion in Zukunft entfernt,  ich bitte sie deshalb sie im nächste SiriusGallery / PragmaMx Update  abzuändern, das man auch on Zukunft die Sirius Gallery nutzen kann. Weil irgendwann ist PHP 7.2 Standart.
Aus diesem Grund benutzte ich für diese Seite deshalb PHP 7.1x
Titel: Re: Sirius Gallery funktioniert nicht bei PHP 7.2.2
Beitrag von: TerraProject am 20 Februar 2018, 20:02:36
im Moment sind wir bei 7.1.14 angelangt und die ist erst am 01.02.2018 veröffentlicht wurden. Die 7.2.2 auch gerade am 01.02.2018. Also sein mal ganz relaxt.  :cool: Mit einer PHP-Version 7.1.x bist du sehr gut unterwegs und keinesfalls sehe ich im Moment einen Standard bei 7.2. Schau dir mal Programme, wie das SMF oder die Coppermin-Galery an, die sind nicht mal soweit wie wir, da iat max PHP 5.x möglich......
Unter 7.2. werden auch noch andere Funktionen als veraltet gekennzeichnet ....

Also schön Füsse stillhalten.... wir bleiben dran..... :bye:
Titel: Re: Sirius Gallery funktioniert nicht bei PHP 7.2.2
Beitrag von: Uli2003 am 23 November 2018, 16:37:20
Da ich auch gerade mal die Sirius Gallery ausprobiere unter 7.2/7.3, habe ich die Codezeilen um 2228 wie folgt abgeändert:

                $value = preg_replace_callback('/\022([^\024]*)\024/',
               function($match) {
                return "<".stripslashes(strtr($match[1], array("&gt;" => ">","&lt;" => "<"))).">";
                } ,
            $value);



Bisher läuft alles.