pragmaMx Support Forum pragmaMx Support Forum

Neueste Beiträge

Seiten: 1 ... 8 9 [10]
91
integrierte Module / Re: Blöcke im Documents
« Letzter Beitrag von fjuergens am 03 September 2021, 13:37:15 »
Hallo Olaf, sage ich erstmal Danke.....

Werde es nachher einspielen und berichten......

92
integrierte Module / Re: Blöcke im Documents
« Letzter Beitrag von Olaf am 03 September 2021, 10:02:35 »
so....
im Anhang das komplette Modul Documents. Es sind sehr viele Dateien betroffen, deshalb das komplette Modul austauschen. Ich habe auf einer Testseite 2 Kopien von Documents laufen lassen, mit entsprechend unterschiedlichen Blöcken und, und, und....

Solltest du eigene Änderungen im Modul gemacht haben, dann sichere dir diese.

1. Backup machen vom alten Documents und Kopien
2. den Inhalt der ZIP Datei auf den FTP in den Ordner modules kopieren
3. unbedingt darauf achten das alle Dateien überschrieben werden.
4. auch in die Documents-Kopien jeweils den Inhalt von "Documents" kopieren.

Block-Cache leeren !!!
Kompletten Cache leeren

Testen.
93
integrierte Module / Re: Blöcke im Documents
« Letzter Beitrag von Olaf am 03 September 2021, 07:17:34 »

1 Feststellung im Zusammenhang mit Documents:
das das posten der Documente zu Facebook und Twitter scheint jetzt zu gehen. . .
:drinks:

Wenn es jetzt noch mit den Blöcken klappen würde..... genial
bin dran   :yltype:
94
integrierte Module / Re: Blöcke im Documents
« Letzter Beitrag von fjuergens am 02 September 2021, 19:39:59 »
Hallo Olaf, habe heute mal testweise das Update auf die 2.7.2 eingespielt,
hat prima geklapppt....

1 Feststellung im Zusammenhang mit Documents:
das das posten der Documente zu Facebook und Twitter scheint jetzt zu gehen. . .
warum auch immer

habe es mit mit 4 Browsern getestet und war OK

Das zu Deiner Info

Wenn es jetzt noch mit den Blöcken klappen würde..... genial

Gruß Fritz
95
Installation & Update / Re: Installation PragmaMx 2.7.1
« Letzter Beitrag von Olaf am 02 September 2021, 11:30:25 »
Moin Olaf.
Bedeutet das jetzt, dass man von 2.6 auf 2.7.1 updated und dann 2.7.2 drüber spielt, bevor man das Setup startet….
genau so sollte es gehen
96
Installation & Update / Re: Installation PragmaMx 2.7.1
« Letzter Beitrag von Biker am 02 September 2021, 11:16:10 »
Moin Olaf.
Bedeutet das jetzt, dass man von 2.6 auf 2.7.1 updated und dann 2.7.2 drüber spielt, bevor man das Setup startet….oder wie wäre die korrekte Vorgehensweise?
🤔
97
Zusatzmodule / Re: Frage zur Datenbak Modulinstallation
« Letzter Beitrag von Olaf am 02 September 2021, 09:01:37 »
ich habe mal das _blank-Modul wieder vorgeholt....
 :yltype:
hier zum Download
98
Zusatzmodule / Re: Frage zur Datenbak Modulinstallation
« Letzter Beitrag von lenzen24 am 02 September 2021, 07:19:40 »
Moin,
Danke für die Infos erstmal so weit.
Gruss
Sascha
99
Zusatzmodule / Re: Frage zur Datenbak Modulinstallation
« Letzter Beitrag von Olaf am 01 September 2021, 22:13:45 »
erstmal zur Terminologie: "Plugins" haben keine Ausgabe, "Module" schon. das Gästebuch ist ein "Modul", auch daran zu erkennen, in welchem Ordner die AddOns liegen.....

Ich gehe davon aus, daß du ein "Modul" meinst.

1. das Gästebuch ist aber so was von alt, das taugt sicher als Vorlage wenig. es sei denn, du hast dich ausschließlich an der Modulstruktur orientiert.
2. die install.tabledef.php wird nur von der Setup-Routine aufgerufen, sonst nicht
3. im Moment musst du dich (noch) selbst darum kümmern, dass di Tabellen angelegt werden. Am besten im Adminbereich, wenn das Modul aufgerufen wird, einen Test zu machen, ob die Tabellen vorhanden sind, ansonsten anlegen lassen.... (so hab ich es bisher gehandhabt)
4. bitte darauf achten, das für PHP8 schon zu programmieren. am Besten auch alles in Klassen kapseln.....

Wenn du Fragen hast.... melde dich, oder info auch hier

Zukünftig ist geplant : bei Aktivierung eines Moduls eine Datei im core-Verzeichnis aufzurufen (z.Bsp.: activate.php), bzw. die Module über eine Installationsroutine zu kopieren und installieren, inkl. ggf. Datentabellen (dann wird auch die install.tabeldef.php aufgerufen)
Bei den Plugins wird das schon so mit der activate.php gehandhabt.

...ich muss mal das LeerModul wieder vorholen.....  :gruebel:
100
Zusatzmodule / Frage zur Datenbak Modulinstallation
« Letzter Beitrag von lenzen24 am 01 September 2021, 21:03:53 »
Hallöle,
ich möchte ein Plugin erstellen und nutze als Vorlage das Gästebuch.
Soweit so gut, alle Datenbankangaben, Sprachfiles etc angepasst und in das modules Verzeichnis geladen.
Wenn ich mich jetzt im Adminbereich anmelde, dann kommt eine Fehlermeldung der mx_db_mysqli.php das die Datenbanktabellen nicht existieren. Von der Fehlermeldung aus kann man auch den Adminbereich nicht mehr erreichen.
Logisch existieren die Datenbanktabellen noch nicht, das ist auch soweit klar. Wenn ich die per sql anlege, dann funktioniert ja auch alles wie es soll, ABER....
Sollte es nicht so sein, dass ich ein Modul erstelle im modules Ordner reinpacke, mich im Adminbereich anmelde, das Modul aktiviere UND dann die Datenbanktabellen angelegt werden?
Die Datei dazu ist ja im Gästebuch vorhanden:
core/install.tabledef.php

Wo liegt mein Denkfehler? Oder habe ich was übersehen?

Gruss
Sascha
Seiten: 1 ... 8 9 [10]